0

I run Mountain Lion 10.8.4 on a Mac Mini 2012. Over the past year or so (dating back to my older iMac mid-2010, after which I transferred the data to my current Mac Mini), I've noticed that most of my files in Time Machine are getting locked. The files on my Mac are not locked, but the backed-up versions of the files are locked. The icons have a padlock icon on them. This is NOT due to the "auto-lock documents" feature, since this no longer exists in Mountain Lion.

For instance, my Firefox profile is a good example. Here are two screenshots:

  1. Screenshot of my Firefox profile. Everything looks fine.
  2. The same profile, except the latest Time Machine backup.

These locks appear in every single backup I have, up until the oldest one. I ran "Repair disk" on Time Machine, which took about 30 minutes, and then made another backup, and this time the newest backup did not have any locks—but all the older backups still had locks. I found this a bit strange, because why would a backup I made AFTER running "Repair disk" be fixed, but the older ones remained unaffected?

Anyway, I hoped that this would fix the problem, but every time I do this, a few weeks later, the problem re-occurs.

So, is there anything more permanent that I can do?

0

I just tried "Reset Home Folder Permissions and ACLs" and it looks like it might be helping. I ran this for about 30 minutes, canceled it because it took too long, backed up Time Machine again, and noticed that Time Machine backed up some files that I did not touch. Turns out that these files were the same ones being locked in backups, and in the latest backup, they were no longer locked.

So perhaps I was having permission problems with the files that were getting locked? I don't know if this "fix" will resolve this permanently, or just for now, but it certaily seems to be related.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .