0

This is driving me nuts. I created a Font Library or Font Collection (I don't even remember exactly anymore) in Font Book.

I was silly enough to add a very large amount of non-previously-installed fonts into such Library/Collection (around 1000 of them). It might also be relevant to add that all those fonts are stored in an external hard drive. So when I added all those fonts, my computer just froze.

Now, the problem, is that I cannot even start Font Book anymore. Whenever I try to launch it, my computer would just freeze. My guess is that it is trying to configure all the fonts but is unable to finish. I already tried leaving it on for several hours with the Font Book open, but it did not solve my problem.

I think that I should just delete the Library/Collection without launching the Font Book and restore its default settings during the process.

How can I achieve this? Has anyone encountered such problem before?

  • Same problem, did you find a solution? – Matte.Car Sep 1 '15 at 19:28
1

You can use Pacifist to reinstall Font Book in your system. It will ask you if you want to replace it. You will need an image of your OS in an accessible pack.

Don't know if you can 'rm' the folder's content. Never tried, but fonts must be installed in the user's location and not in the System folder.

I think with 'setenv' we can link external folders with custom organized fonts to system/paths.

I'm working around because for years I used many fonts and tried to reorganize them with a minimal system set and no third-party apps like FontExplorer or others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .