2

Font Book has Smart Collections, which allows you to filter based on font properties. I created a Smart Collection with the filter "Languages include:"

It works if I enter "French" or "Japanese", but if I use "Chinese", there are no results.

I looked in a Chinese font's properties (e.g. Baoli SC), and it lists "Chinese (Simplified)" under Languages. I tried all of these search terms, but none worked:

Chinese
Chinese*
Chinese (Traditional)
Chinese (Simplified) 
Traditional
*Traditional*
Simplified
*Simplified*

It seems to me a major oversight/bug that Font Book's Smart Collection filter cannot search for a term that has spaces in it. (Or is there a way to "escape" a space?)

Side note: In Yosemite, some of the Chinese fonts' Language properties have "Chinese, Chinese (Simplified)", so those will show up if you do a Smart Collection for "Chinese", but not "Chinese (Simplified)". In Sierra, however, none of the Chinese fonts' Language properties has "Chinese" alone.

  • 1
    This is possibly a bug affecting Yosemite that has since been fixed by Apple. – woody993 Aug 22 '18 at 6:13
1

I created a Smart Collection on High Sierra for filtering Chinese fonts.
It's an Any rule set consisting of three separate Languages include tests for: Chinese, Chinese (Simplified), and Chinese (Traditional).

Smart Collection Rules

0

This is a Sierra bug. You have to be in 10.11 or 10.13 for Chinese smart collection to work. Same for some other languages I think.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .