A click on "Install App" does nothing. No error message, no download. I am trying to download an app appropriate for my installed OS.

I've rebooted and signed out/in at the app store. No change.

I'm editing because this appears to be the same issue. I signed out and into the app store, and am trying to update existing software.

enter image description here

This is the resulting error message. It references "other account" but this is the account I use, exact same ID I just signed in with.

  • Out of curiosity, what app were you attempting to download? I ran into this yesterday when trying to download Yosemite from a Mac running 10.6.8.
    – Mr Rabbit
    Commented Dec 13, 2014 at 0:53
  • itunes.apple.com/us/app/numi/… - numi a free (today) calculator app. But then I tried other downloads, none would work. Nor would an update to an app I already own. Commented Dec 13, 2014 at 1:52

4 Answers 4


Try resetting the Mac App Store.

  1. Enable the debug menu and restart the Mac App Store.

    defaults write com.apple.appstore ShowDebugMenu -bool true
  2. Choose the Reset Application option and restart the Mac App Store.

    App Store Debug Menu

  • Thanks. I went through the steps above, and no change. Now trying to figure out if I can reload just the Store or I need to reinstall full OS to fix this. Commented Dec 13, 2014 at 13:46

After struggling with the error message of "updates for other accounts", I found a solution to all of it.

The apple forums offered the solution through the debug option.

Type defaults write com.apple.appstore ShowDebugMenu -bool true into terminal and a combination of Cache Buster, Clear Cookies and Reset App did the trick.

enter image description here

After that, the apps were able to update. FWIW, I tried download a new app, but wasn't quickly able to find a Snow Leo app. 10 tries, and all wanted a newer OS.


Maybe deleting Mac App Store cache can help you. Open Terminal and type:

open $TMPDIR../C/

This should open Finder. Delete the com.apple.appstore folder and relaunch Mac App Store see if it works.


Sometimes, you just need to sign out and sign in again to the Appstore. Worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .