11

I'm trying to download the latest version of El Capitan (10.11.4) to build an updated flash drive installer. I fire up the App Store, click the OS X El Capitan link on the right, then click the Download button. A pop-up warning asking:

Would you like to continue? OS X v10.11.4 is already installed on this computer. Use the Updates page to install the 10.11 update or if you would like to download the full OS X installer click Continue.

Since this is indeed what I'd like to do, I click the Continue button. The pop-up goes away and the spinner in the upper left keeps going. Eventually, I get tired waiting for the spinner to stop, so I'll go to a different desktop and do stuff or minimize the App Store window. When I return to it, the spinner is gone, nothing is downloaded, and I can no longer click the Download button. (The text appears slightly less dark.)

I can exit the App Store, restart it, go back to the El Capitan page and do the whole process again, but nothing seems to let me download the full, latest version of 10.11. Even if I use defaults to enable the debug menu on the App Store, bump the logging level up to 4, there's not a lot of info shown in Console.

Restart didn't change behavior. Disabling the Little Snitch network filter didn't affect anything.

Any suggestions for how I can d/l this version to build an updated install drive?

  • 1
    Check your main Applications folder or - if you have moved an older OS X El Capitan installer.app to a different folder - this second folder for the app. I have a "Installer" folder in my user folder dedicated to OS X Installer apps (the latest but also older OS X versions) and the single installer.apps will be downloaded (or "updated" to the latest version) there. – klanomath Mar 23 '16 at 15:52
  • Thanks for looking into this, @klanomath. I did check /Applications and ~/Applications for Install\ OS\ X\ El\ Capitan.app, but found nothing there. Since I had moved the installer to my Desktop folder, I looked there to see if it was updated, but it hasn't been touched since late October 2015. – Sigsegv Mar 23 '16 at 15:59
  • Two other things to note 1 I had updates available for other apps. Whenever I clicked the update button, I saw the storedownloadd process log an AssetDownloadOperation message. I saw nothing when I tried to download EC. (That said, could be the difference between an update and a straight download.) 2 I saw mention somewhere of the Download button changing to Downloading when it actually starts downloading. This didn't happen for me, but I also don't know how reliable that is. – Sigsegv Mar 23 '16 at 16:07
  • 1
    I would rather check the version of the file: cat /Path/to/Install\ OS\ X\ El\ Capitan.app/Contents/Info.plist | grep 15. If the result is 15E64 it's 10.11.4 – klanomath Mar 23 '16 at 16:08
  • └─[0] <> grep 15 Install\ OS\ X\ El\ Capitan.app/Contents/Info.plist <string>15B41a</string> <string>Install OS X El Capitan, Copyright © 2007-2015 Apple Inc. All rights reserved.</string> <string>15B41a</string> – Sigsegv Mar 23 '16 at 16:10
8

Here's how I did it! - Open Mac App Store - Go to Purchased - Look for El Capitan - Hold the Option Key + Click Download, you should see the progress bar in front of it.

You're done!

  • 1
    Sadly it's not working here. I purchased it, I see it, but if I click on "Download" I get the error message anyway (probably because on this mac I'm on Sierra already) – phaberest Feb 1 '18 at 14:00
5

I had the exact same issue. The culprit, in my case, was that I had older versions of the installer in other locations on my drive.

The solution was to move all older versions to the Trash and reboot. I did not empty the Trash, however (just in case). Upon rebooting, the App Store behaved and I was able to re-download the complete OS 10.11.4 installer. Then I emptied the Trash of all of the older versions.

  • I'd second second. Usual problem is you have it somewhere like on differnet partition open – iskra Aug 30 '16 at 17:54
2

Same problem on my MacBookPro6.1 17" Mid-2010. In my case, the solution was taking these steps:

  1. Signed Out of App Store;
  2. Searched for "El Capitan" by using the App Store search bar;
  3. Clicked on "El Capitan" on the search results;
  4. Clicked on the button to get it;
  5. Provided my email/pass when App Store asked for them;
  6. Confirmed App Store question to buy it.

After these steps, the download started immediately. When the download was finished, the file "Install OS X El Capitan.app" was placed on "/Applications" folder.

  • 1
    This did the trick on my MacBookPro 13" mid 2012. Sign out from the App Store. – andy May 9 '16 at 14:27
1

Had this exact problem. Tried the Sign-out of App store recommendation and still failed. When the store is trying to download the OS X El Capitan installer app, it scans all your mounted drives to see if you already have the installer. If it finds an older El Capitan installer app (in my case I saved a backup copy on a separate volume to free up space on my startup drive), it will determine you're ineligible for download of the full installer app and point you to install the update from the Updates store instead. Even if I clicked Continue, the download would just do a spinning sprocket and never prompt me for my App Store log-in. Once I unmounted my backup volume with the old installers, the App Store prompted me for log-in and began the download of the latest El Capitan installer app.

  • Thanks for the suggestion, Guido, but I still don't get prompted to log back in once I've removed the installer and logged out of the App Store. – Sigsegv May 26 '16 at 20:36
0

You're doing nothing wrong procedurally. The servers are busy is the likely problem. I would restart your Mac (perhaps in safe mode) and try once again. Looking in /var/log at the system.log, commerce.log and install.log might show an actionable error.

Assuming you haven't installed other software that's modifying things network wise - you may need to wait things out or try from a new user account - try from another clean OS install.

In time the error should clear up. You could also download things directly:

  • Thanks for the advice, @bmike. I didn't see much in those log files that stood out as anything actionable, even if I dialed the debug messages back to the default level of 1. – Sigsegv Mar 23 '16 at 17:35
  • I do run Little Snitch, but put that into bypass mode, just in case that was the problem, but it didn't help. I asked a cow-orker who is on the same network and also running Little Snitch to do the same process that I did. I watched over his shoulder and things worked as they should. That pop-up came up, he clicked "Continue," then got prompted to log into his Apple account. After that, the Download button changed to Downloading and everything proceeded as expected. – Sigsegv Mar 23 '16 at 17:36
  • I tried logging out, then downloading 10.11, but after the pop-up, the busy spinner came up with no prompt to log into my account. – Sigsegv Mar 23 '16 at 17:40
  • Great work @Sigsegv - If you wanted to post that as an answer with a picture of the dialog you select, it might help others. I'd +1 that answer :-) – bmike Mar 23 '16 at 18:46
  • Thanks, @bmike. While I was able to route around the problem by getting a cow-orker to do the download for me and give me a copy of the installer on a flash drive, I'm still not sure why it's not working on my late-2013 15" MBP. – Sigsegv Mar 23 '16 at 19:38
0

I rather skeptically followed Lucas Brero's instructions. In my case, the trick seemed to be---I needed to accept new terms and conditions. These were only presented after I followed those instructions! Then, the button changed to "Downloading" and I got a progress bar.

  1. Sign Out of App Store
  2. Search for "El Capitan" by using the App Store search bar
  3. Click on "El Capitan" on the search results
  4. Click on the Download button
  5. Provide Apple ID and password
  6. Confirm terms and conditions
0

I ran in to this issue as well only to find out the I had to agree to some new license agreements in the app store prior to downloading. Silly thing was it did not tell me until after I updated/restarted and such. Once I agreed I tried again and low and behold it worked.

You must log in to answer this question.

protected by Community Oct 12 '16 at 16:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .