1

Whenever I try to insert " or ' I have to validate it by space, otherwise strange things happen as with ' followed by an a becomes áinstead of just 'a, similar behaviour with double quotes. I find this annoying and want to disable it. How do I do that?

  • Does it do it when you type in "here" or 'a ? – Ruskes Jul 30 '13 at 13:49
4

The problem lies in your keyboard layout which uses 'dead keys', probably your keyboard layout is US International.

Go to System Preferences -> Language and Text -> Input Sources and choose another layout, such as US Extended.

  • Thank you! This was driving me insane. What do you mean exactly by "dead keys"? – bernk Sep 17 '13 at 20:09
  • Dead keys are keys that stick and modify the next key you press, producing the behaviour described in the original question. An alternative is to use a layout with modifier key dead keys, such as US Extended, where you have to press option key along with the quotes, carets and other modifier characters to get diacritics. en.wikipedia.org/wiki/Dead_key – Jozef Legény Sep 18 '13 at 7:47
  • I had no idea that keyboard layouts changed this behaviour. For years and years I have assumed this to be a function of the OS, not individual layouts. Thanks again! – bernk Sep 18 '13 at 11:01
0

If others were searching for how to convert dead keys to normal keys in a keyboard layout like German or French, you can create a new keyboard layout with Ukelele.

  • Choose File > New From Current Input Source. It also assigns a new ID to the keyboard layout in newer versions of Ukelele.
  • Double-click each dead key, select Set Output, and enter the output.
  • Save the keyboard layout as a bundle or an XML file to /Library/Keyboard Layouts/. Keyboard layouts in the user library can't be selected in password dialogs or on the login window. XML keylayout files don't work with the popovers shown when holding keys, but bundles include additional files like an Info.plist.
  • Log out and back in and enable the input source from System Prefefences.

To apply changes to a keylayout file or bundle, run sudo touch /Library/Keyboard\ Layouts/ and log out and back in. You can disable other input sources by editing the HIToolBox plist.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .