88

No, dear readers, as the Internet might have you believe, none of these things work on a 2017 Macbook Pro, the kind with the touchbar:

  • Fn+Enter
  • Fn+M
  • Fn+.
  • Fn+Option+Enter

Somehow, someway, when I was pasting some text I ended out getting into overtype mode in Slack and now it's stuck that way.

Internet documentation might work if I had an older computer or one with keys that I don't have, but there's nothing I've been able to find that will tell me how to turn off this dratted overtype mode. And it's seriously annoying.

Any clue how to turn it off?

6
  • 1
    Did you contact Slack support on this?
    – nohillside
    Nov 3, 2017 at 14:26
  • @patrix not yet - I had a look in the slack help and there was nothing which suggests it is an macOS issue :-\ Nov 3, 2017 at 14:33
  • I just now have the same issue!
    – Harlan
    Nov 6, 2017 at 15:31
  • 1
    So frustrating! Nov 21, 2017 at 18:24
  • 1
    Saved my frustration, saved my day! Apr 14, 2020 at 14:34

8 Answers 8

81

My original solution (crossed out below) no longer works. Things that do work:

  • If you have a Mac keyboard, press the Help key to toggle between insert and replace mode
  • If you have a Windows keyboard, press the Insert (or Ins) key to toggle between insert and replace mode
  • Restart Slack (quit and relaunch); refreshing no longer works

I contacted Slack support and was told to use +R to do a quick refresh and reset the mode from overwrite to insert.

From Slack support team:

> Thanks for writing in about this! We've seen this occur on Mac computers recently as well, and the good news is there is an easy way to switch! To reset the mode from overwrite to insert, this should be possible with a quick refresh using Cmd+R

Explanation: This is because slack is using electron, which is essentially a wrapper around a browser to create a desktop app. Other "web" commands work like +[ and +] to traverse your "browser history" backward and forward, respectively.

6
  • FYI this workaround also works on Ubuntu using Strg+R
    – ATN
    Aug 22, 2018 at 7:39
  • 5
    Just a refresh didn't work for me. I had to close the chrome tab and reopen it.
    – Semimono
    Dec 17, 2018 at 23:52
  • +1 This worked for me! I had the same problem, but it didn't originate in Slack for me. It was affecting other apps, including IntelliJ. It happened at home when I accidentally pressed Ins on a windows keyboard. At work I have an Apple keyboard with no Ins key so I couldn't toggle it off. After reading this answer, I was able to use ⌘+R in Slack to toggle it off though. Thanks!
    – tune5ths
    Dec 10, 2019 at 22:14
  • 4
    As of Slack version 4.6.0 / Catalina, the ⌘+R fix no longer works. It used to for me, but that was on older versions of MacOS and Slack, so I don't know which upgrade broke it. Closing & restarting the Slack app was the only thing that worked.
    – JESii
    Jul 1, 2020 at 17:27
  • 1
    ⌘+R, restarting all did not work. I have Ubuntu 20.04, the Slack app (Snap 4.9.1 64-bit) and an apple keyboard (don't ask), so pressing the help key is what worked for me.
    – iggie
    Oct 2, 2020 at 21:46
48

Closing and restarting Slack worked for me... But yeah, super annoying!

3
  • 1
    Just had this happen to me, had to restart Slack as well - it's like the old Windows days, just reboot to fix....
    – ckm
    Nov 29, 2017 at 18:50
  • It kills me that this is still a problem and I still have no idea how it happens or how to fix it other than restarting Slack.
    – user24601
    Mar 11, 2020 at 19:15
  • On Windows I killed all Slack tasks in Task Manager, then opened Slack again. Done.
    – Jono
    Sep 14, 2020 at 12:20
13

NOTE: Keep in mind that if you're using a PC keyboard with your Macbook, then this solution can be used.

Press insert on your keyboard. Fixed.

0
8

I am using an old Apple keyboard. The 'help' button turns on/off the overwriting function on the computer.

3
  • +1 While your answer might not have been specific to the question it solved my problem in R Studio. Dec 4, 2018 at 19:26
  • Thanks for this. I'm also using an older Mac keyboard and this fix it for me too. Jan 15, 2019 at 20:03
  • This should be the correct answer as it's not specific to any environment/app Apr 17, 2019 at 18:03
4

Ctrl+R for you windows users out there.

0
3

I was trying to figure this one out too and couldn't find anything that worked. What I did, ultimately: Run the On-Screen Keyboard in Windows and click the INSERT key.

enter image description here

enter image description here

2
  • Ummmm.... how is this related to Apple?
    – Allan
    Mar 13, 2020 at 0:12
  • 2
    This is what did it for me! But I'm weird - I'm using an Apple USB keyboard on a Windows box. :P
    – Narfanator
    Mar 29, 2020 at 11:11
1

I know this an apple SE, but some of us use Mac and Windows. In my case, using a Windows laptop in a docking station, pressing the Insert key from the external keyboard didn't solve the problem, but pressing the Insert key on the laptop's built-in keyboard solved it.

TL/DR: If you use an external keyboard, try clicking Insert key on the built-in keyboard.

1
  • 1
    I'm using a kinesis + Mac, and the opposite was the case for me. I'd accidentally toggled Keypad on my keyboard, and didn't know there was an insert key on the left-hand-side under \ |
    – wrhall
    Jun 8, 2020 at 21:19
0

I'm using it on a windows 10 machine in chrome. Control-r doesn't seem to work here. Even though I had closed the chrome browser and shut down the machine, when I brought it back up the next day it was still in overtype mode. I had to close that tab in the browser and then open slack in the browser again to go back into insert mode.

1
  • Try Pressing: fn + 0 NOTE: 0 of the right number keypad or Try Pressing: shift + fn + 0 . NOTE: 0 of the right number keypad
    – sgupta
    May 2 at 3:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .