0

I am using my Mac to write Java code in Eclipse. Not frequently, but commonly enough I need special characters such as ^, ~ or `. The problem with these is that I have to press the key(-combination) followed by a space in order to insert the character, since these keys are used to create special characters such as ã or è. However, this is really impractical since I can't use them in Java anyway.

Is there a way to disable this feature globally on OS X Yosemite (german keyboard layout)?

  • So, for example, you want option + n to produce tilde right away without a space being required? – Tom Gewecke Mar 1 '15 at 16:04
  • Exactly. Pressing Option+n generates an 'underlined' tilde character, and pressing another key such as 'a' replaces the underlined tilde with 'ã'. – Clashsoft Mar 1 '15 at 16:06
  • I don't know any way to disable that except by creating a custom keyboard layout. The apps for that are Ukelele and Karabiner. You could do text replacement entries in system prefs/keyboard/text, but that would normally still require an extra space. – Tom Gewecke Mar 1 '15 at 18:27
-2

You just need to change input source. Probably you have U.S. International, just change it U.S. and this ugly feature will disappear.

| improve this answer | |
  • Hi, welcome to Ask Different. Thanks your for answer, but the OP states in the question that the keyboard layout is German. – jaume Jun 30 at 10:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .