3

The question Type straight quotes (",') when smart quotes is turned on answers this quite well for macOS, but the solution (using a text replacement with the straight quote as the replacement phrase) does not appear to work in iOS:

shortcuts returning straight quotes

I like to use the typographically correct smart quotes, but when I need to edit text in a markup or programming language, it’s frequently the case that I need to enter straight single and double quotes.

These text replacements pictured (and more such as exactly the ones mentioned in the macOS solution above) don’t get replaced at all if they contain quotes (either straight or curly) in the shortcut. On the other hand, if I use a text replacement like the ^^s at the bottom here:

more examples of text replacements

I get a character, even though the replacement’s phrase is the ' character. (Note that the examples above that one also beginning with double-carets, such as ^^1 → ¹, ^^9 → ⁹, etc., work just fine—I used them in this sentence to type those superscript digits.)

I’m looking for a way to set a global hotkey to toggle smart quotes, a macro to insert a single or double straight quote, or anything easier than my current two methods:

  1. Go to Settings → Keyboard and toggle the smart quotes, type the straight quote, and go back to Settings → Keyboard and toggle them back (this is what I do when I need to only type straight quotes for a period of time); or
  2. Find a single quote or double quote somewhere and copy/paste it. (This is what I do when I must mix the two in ongoing text editing.)

Both are painful. I’d appreciate any trick to make it less so!

3 Answers 3

0

With the touchscreen keyboard, you can long press the and key to get a popup where you can select variations of the quotes, including ",«,»,. Note that the options and their locations change with the input language. In Ukrainian & English(US), just long press and release would give you the ASCII quotes.

6
  • I just tried this and it doesn’t work. I just get “”””””””, ‘’’’’’’’’, etc. It repeats like many keys do. It works with vowels — I can long-hold E and then press 4 to get ë, for example.
    – Trey
    Commented Jun 16 at 23:03
  • 1
    Works for me on iOS & iPadOS 14's touchscreen keyboard. Are you using an external keyboard? You won't get one with external keyboard! In that case use the option key combo, or try using ctrl+'.
    – hym3242
    Commented Jun 17 at 9:08
  • The title does say "external keyboard", so the touchscreen is not really an answer Commented Jun 17 at 10:47
  • @TomGewecke I suggested that edit adding "external keyboard" to title when I finally found out that external keyboard is what OP wanted.
    – hym3242
    Commented Jun 17 at 11:11
  • I’d note that when I wrote my OP, long-pressing the virtual keyboard let you move the insertion point like arrow keys; the change to make it offer character variants came later that year. Since the problem originally pertained either way, the clarification now is useful. But what is “the option key combo”? (And ctrl+’ produces the same thing—I, in fact, used it right there to type ctrl+’. And that would only give single-quotes even if they weren’t curly.)
    – Trey
    Commented Jun 17 at 22:25
-1

I’ve the same problem. I recently filed a Feedback ticket (iOS 15.2 is the current version) to request Apple consider making toggling this switch easier via shortcut or adding an option to select the setting on an app level instead of globally. Let’s hope they take my suggestion.

1
  • This does not really answer the question. You can follow it to be notified of any new answers. If you have enough reputation, you can upvote the question and/or add a bounty to draw more attention to this question.
    – Glorfindel
    Commented Dec 25, 2021 at 20:27
-1

The smart replacement function is called after the user defined replacement function. You can't win if you keep the smart replacement sabotaging what you define.

I suggest you my plain stupid approach: I removed the smart replacement function in MacOS and iOS because it's too smart for me to use it in a brain efficient way. I feel it's really smart for the "racing typist", but not at all for me who type in many foreign languages, programming, math, physics, graphics… I must admit I am far from the mass market ideal racing typist which Apple is targeting.

Then I trained to use the Apple ergonomic shortcuts ( these were introduced 30 years ago by Apple, around 1986 if my memory is still OK ) to enter the curly quotes or quotation marks I need within the different languages I have to type correctly:

+\ → «

++\ → »

++] → ’

+] → ‘

...

and on iOS I simply use the popup of

" to get the « or the ”

...

This way I am able to type french, german, spanish, US, shell, C, Perl, math, physics without too much pain in the fingers and in the brain.

6
  • Unfortunately, there is literally no way, regardless of opt chords, to get a » symbol out of the iPad’s Ukrainian hardware keyboard map without smart quotes turned on—you can only produce the « symbol. So this solution isn’t an answer for me.
    – Trey
    Commented May 25, 2022 at 16:29
  • I switched on the ukrainian keyboard on my Mac. And [⌥]+[=]→» and [⌥]+[⇧]+[=]→«. But I can't test it on an iPad: I don't have one. How do you get a simple " on an iPad keyboard?
    – dan
    Commented May 26, 2022 at 21:01
  • 1
    Dan's shortcuts work fine on my iPad with the Ukrainian mapping. Commented May 26, 2022 at 22:01
  • I don’t know what to tell you—I’m on my iPad right now, I’ll switch to Ukrainian: Українська. If I switch and type, for instance, ⌥=, ⌥⇧=, ⌥\, and ⌥⇧\, here’s what I get: ъЪёЁ. By typing ⇧2 twice I get «» with smart quotes on. In any case, there was once a time I needed “smart” chars much less often than “straight” single and double quotes, but that time has passed (especially since most code editors & terminals turn smart quotes off locally now). I really need a way to do the straight ones as the exception, not as the rule.
    – Trey
    Commented May 28, 2022 at 20:18
  • I think you should improve your OQ to clearly state this is an Ukrainian iOS keyboard problem. A screen capture of this keyboard, plus the one with the numerical setting, with the key you use to type in normal mode ( without the smart mode on ) a normal quote would help people of good will to help you.
    – dan
    Commented Jun 1, 2022 at 20:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .