1

I'm facing a rather frustrating issue with my MacBook Pro 16. While typing, I often accidentally touch the Touch pad, which triggers the Privacy & Security window to pop up. This is becoming quite annoying, and I'm looking for a way to stop this from happening.

Here's what occurs: enter image description here

I'm not sure what causes this specific window to open, but I'd like to either disable this feature or find an alternative solution that prevents the Touch pad from opening this window unintentionally.

Additionally, I'm including the configuration details of my MacBook for reference: MacBook Pro 16-inch, 2019

  • Processor: 2.6 GHz 6-Core Intel Core i7
  • Graphics: AMD Radeon Pro 5300M 4 GB
  • Memory: 16 GB 2667 MHz DDR4
  • macOS: Sonoma 14.1

Any advice or solutions would be greatly appreciated!

5
  • Voting to close. You've left out essential details: What are you pressing on the Touch Bar? Are you using BTT? Screenshots of Touch Bar helpful.
    – JBallin
    Commented Nov 30, 2023 at 4:10
  • @JBallin, i made an error, not touch bar, but touch pad, i don't know what i press on it, this is the point for me to understand why does it work like this, it happens accidently while im typing
    – oruchkin
    Commented Nov 30, 2023 at 9:38
  • 1
    I've just tried to deliberately trigger trackpad 'input' with my palms while typing, and been unable to; apart from actually pressing down and clicking. It's very weird that 'random' trackpad input would consistently open the Privacy panel. Do you get any alert or dialog? Do you have any third-party utilities installed, that might trigger ANY activity? Also check Settings for your trackpad gestures configuration. (E.g. what happens when you two-finger drag, etc.) Are you able to deliberately open the Privacy panel with a specific gesture?
    – benwiggy
    Commented Nov 30, 2023 at 13:39
  • 1
    Hmm Touch Pad? Do you mean Trackpad?
    – JBallin
    Commented Nov 30, 2023 at 18:52
  • 1
    First thing to check is your trackpad settings, like ben said. You can set up shortcuts there like hot corners etc. that you may be triggering by accident. You could also check accessibility settings.
    – JBallin
    Commented Nov 30, 2023 at 18:53

1 Answer 1

0

I found the core problem thanks to @benwiggy comment, he led me the right way, so if it is possible I would give a bounty to him.

After upgrading to macOS Sonoma in my Touch Bar, was added the button Extensions Settings which I can't get rid of, first I thought it only looked bad, but now I understand that it was the problem, I actually clicked on it with my left hand accidentally, and since I was used to the Touch Bar not bothering me before (in OS Ventura) and it was empty, I couldn't figure out what the problem was.

PS to mods, I want to share the bounty with @benwiggy, is it possible? (he guided me to solve the problem)

Photo of the Touch Bar on a Mac laptop with the button 'Extensions Settings' on the left side

2
  • 1
    I'm OK for points. So it was the touch bar, not trackpad. Glad you got it sorted.
    – benwiggy
    Commented Nov 30, 2023 at 21:26
  • AFAIK, there is no way to share a bounty, so just ask benwiggy to post an answer and award them the bounty.
    – Thinkr
    Commented Dec 1, 2023 at 6:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .