14

Problem

My Macbook overheats insanely.

After investigating a bit, I found out that the correlation is extremely strong with having it plugged in to an external monitor with the Macbook Pro monitor also active.

If I unplug the laptop, or use only the external monitor (i.e. Mac in a 'clamshell' mode), the heating stops within a minute.

I managed to use a software (sudo powermetrics --samplers smc |grep -i "CPU die temperature") to measure this:

  • Indoor temperature: 23C
  • CPU heat without external monitor: 55C
  • CPU heat with external monitor + macbook monitor on: 95C (fan turns on)
  • CPU heat with external monitor, macbook closed: 62C

Details of hardware

  • Macbook Pro (16-inch, 2019). 2.3 Ghz 8-Core Intel Core i9, 16 GB 2667 MHz DDR, AMD Radeon Pro 5500M 4GB, Intel UHD Graphics 630 1536 MB
  • macOS BigSur 11.4
  • Monitor: HP E233. 23-inch (1920 x 1080)
  • Cables connecting: UGREEN USB C Hub HDMI USB C Adapter with 4K HDMI, 3 USB 3.0, SD/TF Card Reader (https://www.amazon.de/gp/product/B07RRPS5NT/), and then a standard HDMI-cable

Tried fixes that didn't work

  • Restart
  • SMC reset
  • Never use two monitors (works)

How could I fix this so I can use two monitors also in the future?

4
  • Is your monitor plugged in on the right or left?
    – X_841
    Commented Jul 15, 2021 at 6:56
  • Left. Dont tell me that this makes the difference :-D
    – ppt
    Commented Jul 15, 2021 at 7:15
  • 1
    apple.stackexchange.com/questions/363337/… it may actually be the problem.
    – X_841
    Commented Jul 15, 2021 at 9:00
  • 1
    That trick used to fix the issue in previous versions (I had a 15" 2016 where it worked), but not anymore. I've tried both sides and now it doesn't. I have an i7 and an i9 (both late 2019) and the issue only affects the i9.
    – t3b4n
    Commented Sep 5, 2021 at 3:03

5 Answers 5

2

Try this:

  1. Update to latest macos Monterey
  2. Go to Settings -> Battery => Check the Low power mode both for Battery and Power adapter
  3. On using two 4k monitors, if possible use ports on left/right foreach monitor

Good Luck!

1
  • 2
    I tried this - it had no impact on my machine (16" i9 MPB with a single external display).
    – Nathan S.
    Commented Jan 7, 2022 at 5:33
1

As a MacBook Pro owner, I had the same problem. After a lot of researching, I discovered that our MacBooks have an architectural error: when plugged, an external monitor is always controlled by the dedicated GPU (the AMD Radeon, in my case).

So, as the dedicated GPU is more power-consuming and tends to heat more than the integrated one, our laptops are always overheating when connected to an external monitor.

Sources:

  1. https://dnsmichi.at/2022/01/10/macbook-pro-16-2019-heat-problem-with-external-display/
  2. https://apple.stackexchange.com/a/444119/468509
3
  • "Defiance"? I may be mistaken, but I don't think that is the correct word. Commented Jul 31, 2022 at 13:42
  • Can you please edit in links to the research you found?
    – agarza
    Commented Jul 31, 2022 at 14:25
  • Edited the post to correct that wrong word and to add sources. Thanks for the suggestions. Commented Aug 1, 2022 at 14:04
1

I have the same problem with two 4k monitors (3840x2160). The issue goes away when I use the native resolution, but the text is too small, so I need to scale down. If I use the default scaled configurations under system->displays, then the fans go very high. However, if I use the same h/w ratio, then the fans don't run nearly as loud. I'm using BetterDisplay to manage the screen size, and keep it at the same ratio, which is currently 3008x1692, and no fan issues.

0

try this:

  1. go to [System Preferences] -> [Displays];
  2. go to [Displays Settings] if you are using both built-in monitor and external monitor, otherwise there is not [Displays Settings] and you will see the detail info of the current monitor instead.
  3. remember the Color Profile of the built-in monitor. set the external monitor's Color Profile to the same as the built-in one.
0

In my case, the culprit was a mismatch between the frame rates of external and built-in displays (50 and 60 Hz, respectively). Setting the external display to 60 Hz in System Settings > Displays solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .