3

I'm having problems connecting to an SMB share on macOS Sonoma—I cannot authenticate from a Windows system or a Linux system—I just get a password error. I can only successfully connect to the SMB share from another Mac.

This is from the console log:

smb2_dispatch_session_setup: session_setup_transact status: 0xc000006d --- This is a STATUS_LOGON_FAILURE

I had issues in the past with Apple increasing security on their new OS versions and causing problems with my scripts so I'm thinking they have modified some security settings but I'm not sure what I can do to fix this.

If I connect from Windows to an SMB share on macOS Ventura (which works), I can see in the console log that opendirectoryd runs and seems to be the one authenticating the access but I don't see any of this on Sonoma.

I have tried modifying the SMB protocols in nsmb.conf but that did not help.

To make this more clear—the SMB service is running on macOS Sonoma. I set this up using Settings > General > Sharing > File Sharing. If I set up file sharing on macOS Ventura, I can access the share just fine from Windows. However, if I try to access a file share on macOS Sonoma from Windows, I get a logon failure. I can access the file share on macOS Sonoma successfully only from another Mac.

5
  • Is this an SMB 1 or SMB 2 share?
    – JMY1000
    Commented Oct 8, 2023 at 17:52
  • I have tried both SMB 1 and 2 using nsmb.conf: support.apple.com/en-by/HT211927
    – mw2785
    Commented Oct 8, 2023 at 19:35
  • What OS/configuration is the SMB server that you're connecting to running?
    – JMY1000
    Commented Oct 9, 2023 at 22:49
  • 1
    I have updated my post with more detailed information about how I am creating this SMB service.
    – mw2785
    Commented Oct 10, 2023 at 15:17
  • Sonoma bug not fixed in 14.1 For Windows 11/10: - Windows 11/10 Turn off Password Protect Sharing - Mac: Goto Server and connect as Guest - Only shared folders within Windows 11/10 are exposed
    – MikeInNSW
    Commented Oct 31, 2023 at 22:03

2 Answers 2

4

I had the same issue when connecting from Infuse Media Player to a Mac Mini running Sonoma. Installed Sonoma developer 14.1.3 in a VM and tested this again. Seems to be working.

1
  • 1
    Thank you. It's working now. I just updated my macOS from Sonoma 14.0 to Sonoma Developer 14.1 Beta 3. For others reading this, please note that this option might not be available on your Mac unless you are a registered Apple developer. I'm hoping this gets fixed in the public Sonoma version, though. I can't upgrade my build systems to a beta version.
    – mw2785
    Commented Oct 14, 2023 at 17:39
3

If you don't want to download developer 14.1, there is another workaround. Captitalize any letter in username and try to connect. Every logon you try to connect make any letter capital or small of username and then authentication will be successful.

1
  • FYI, macOS 14.1 is now publicly available.
    – Glorfindel
    Commented Dec 1, 2023 at 16:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .