3

After the upgrade to Sierra on my MacBook Air, I'm unable to connect to the NAS on my home network through Samba. When I try Connect to server and enter:

smb://x.x.x.x/MEDIA/

I get an error saying "this file server will not allow any additional users to log on. Try to connect again later." My Mac Mini, still on OS X 10.9, can still connect to the share.

  • I do not have this problem, but I also noticed that I have to confirm the password dialog again each time I connect. Something has definitely changed. – Max Ried Oct 6 '16 at 15:07
3

Try connecting with cifs://x.x.x.x/MEDIA/ Worked for me!

  • Thanks, but I tried that. Didn't solve my problem. – PoorYorick Dec 31 '16 at 5:03
  • Wow, that works for me too. Do you have an idea as to why cifs would be working when smb isn't? I've been using smb on two MacBook Pros with the same linux samba server for years. It's just since I upgraded to High Sierra that I can no longer access the samba shares from either of my two High Sierra machines. – Jonathan Nov 4 '17 at 0:35
2

I had the same issue. I have a linux server with 2 IP's on my local network, one is set as the DMZ ip on my router that I bind public-facing stuff to (just web and ssh server), the other is internal-only like BIND, etc.

Turns out, when I switched my network from 10.x.x.x to 192.168.x.x, I forgot to update my netmask from 8 bits to 24 bits. Once I did that, share worked immediately. This makes sense as smbd/nmbd need a proper broadcast address for discovery. So check your server and make sure that your mask is correct for your the IP block you're using.

Also, try disabling jumbo frames on the server (make sure MTU is < 2000)

0

I had the same error and solved it. The problem was an entry in the smb.conf of my server. In the [global]-section there was an entry smb ports = 139. If this setting is active the server accepts connections only with port 139 but not with port 445.
After deleting this line and restarting the server the connection was established as expected.
So check if your NAS accepts connections with port 445. I think Sierra uses port 445 with the smb-client.

  • My smb.conf didn't have an smb ports line. I tried adding "smb ports = 445" to it (w/o quotles) and restarted my server. Still not getting through. Thanks for the suggestion, though. It would make sense that there's a conflict between what the server is expecting and what my Mac is sending. – PoorYorick Oct 13 '16 at 4:50
  • If there is no "smb ports"-entry in the smb.conf the smbd service uses both ports 139 and 445. So you can delete this entry. If youre NAS is linux/unix-based and you have a terminal access, you can first check with the command netstat -anp tcp | grep smbd, on which ports the smbd is listen. There should be entries with the IP address of your NAS followed by a colon and the used port number. If there is no entry with port 445 your NAS doesn't listen on port 445. – uldo Oct 13 '16 at 9:04
  • Thanks @uldo, that helped me find out that my Mac Mini is connecting over port 139. I'll try listening on 445 again. – PoorYorick Nov 20 '16 at 21:06
  • I've spent four hours on this today, and I'm nowhere closer to solving this issue. Here's what I know: * Mac Mini (on El Capitan) has a remarkably resilient smb connection to the NAS on 139. – PoorYorick Nov 27 '16 at 22:23
  • Here's what I know: 1. Mac Mini (on El Capitan) has a remarkably resilient smb connection to the nas on port 139. 2. I've tried both "smb ports = 445" and "smb ports = 139 445" in my smb.conf; mini connects regardless but Air (Sierra) doesn't ever; could never see a connection on 445 in nas netstat. 3. my nas is on samba 3.0.23c. 4. I've tried upgrading nas to samba 3.6, but the package binary I'm trying to use is looking for older libiconv and libldap than I can find. 5. My nas is a MyBook World Edition from 2008, which probably means I should upgrad to synology or something. – PoorYorick Nov 27 '16 at 22:34
0

Try this on terminal: echo "[default]" >> ~/Library/Preferences/nsmb.conf; echo "smb_neg=smb1_only" >> ~/Library/Preferences/nsmb.conf

or try cifs://servername instead of smb://servername

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .