I set up an SMB server on my Mac by going to System Preferences > Settings > Sharing and enabling File Sharing. Afterwards, I tried to access it from my Arch Linux laptop. It asked for my password, as I expected, and I enter my Mac's login password. The dialog keeps showing however.

That Pesky Dialog

Using the terminal and entering smbclient -L yeilds the following output on both my laptop connected to the network, as well as in an Arch Linux virtual machine running on my Mac:

 mike@ArchLinux > ~ > smbclient -L
smbclient: Can't load /etc/samba/smb.conf - run testparm to debug it
Enter mike's password: <I enter my Mac's login password here>
session setup failed: NT_STATUS_LOGON_FAILURE

Using PCManFM as my Linux file manager, going into network:/// shows "Windows Network". Going into there links me to smb:///, which then shows "Failed to retrieve share list from server: No such file or directory"

  • Did you make sure to check the box next to your account name under "Options..." in the File Sharing tab of the Sharing prefpane?
    – JMY1000
    Aug 2, 2016 at 5:28
  • @JMY1000 I did try that, but it still didn't work. Aug 2, 2016 at 9:59

1 Answer 1


I had this behaviour with my Mac Mini running MacOs 10.13 after activating File sharing, but NOT authorizing specific users. So my guess is that you simply forgot to enable login for your account.

file sharing screen capture

  • 1
    That worked for me. Because the ‘options..'. button says ‘sharing files with some Windows computers...’ I thought was something specific for WINDOWS not for LINUX, so I didn’t check it. After your message, I check it and everything worked. thanks
    – daniel_hck
    Mar 4, 2020 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .