I see something in my Downloads (fanned from Dock) that I didn't download, named XXkkAgSU

Dragging the icon to Terminal pastes the full path and filename as expected. But the shell can't see it:

WGroleau@MBP ~ % file /Users/WGroleau/Downloads/XXkkAgSU 
/Users/WGroleau/Downloads/XXkkAgSU: cannot open `/Users/WGroleau/Downloads/XXkkAgSU' (No such file or directory)
WGroleau@MBP ~ % rm !$
rm /Users/WGroleau/Downloads/XXkkAgSU
rm: /Users/WGroleau/Downloads/XXkkAgSU: No such file or directory

After those commands, fanning Download from Dock still shows it. But a regular Finder window navigated to ~/Downloads doesn't show it. Dragging icon from fan to Trash does nothing—still in fan and not in Trash.


Something similar happened ages ago but that time the phantom file was in the Trash, and could be seen by shell commands, but couldn't be be deleted.

  • ls -dlOe@ on the file?
    – nohillside
    Dec 2, 2022 at 10:42
  • Wild speculation I cannot test… Items in the Dock are aliases, therefore the file list in the Downloads alias are also aliases, or stored in some plist or xml somewhere. This has somehow become unsynchronised from the actual contents. Fix: remove that plist or the entire Downloads alias & make it re-create. [Trouble is, I don't know how to do this. I don't have a Downloads folder in my Dock & I can't even figure out how to put it back :\
    – Tetsujin
    Dec 2, 2022 at 11:16
  • @nohillside: Although I didn't post it, ls (like file and rm) said there is no such file.
    – WGroleau
    Dec 2, 2022 at 17:02
  • Long ago, in an attempt to fix the Dock consistently showing the old version of an updated app instead of the latest, I found that the items in the Dock were merely paths in its .plist. I wrote a script to replace that .plist with one having the correct path. But it didn't work, because Dock is also an app that loads its .plist at login and periodically rewrites it. But it did not list the contents of Downloads, only the path to it. Apparently, that design changed, because my phantom file was not in the Downloads directory and not in Dock after reboot. But what created it, I don't know.
    – WGroleau
    Dec 2, 2022 at 17:14

1 Answer 1


I would remove the entire Downloads folder from the Dock. (Note: this will not affect the 'real' Downloads folder.) Right-click on it, and under Options, you'll see "Remove From Dock".

Then drag the actual Downloads folder back to its position next to the Trash.

  • Ahhh… that's why I couldn't get it to work. I tried dragging to everywhere except next to Trash. In my defence, I probably haven't had it there in a decade ;))
    – Tetsujin
    Dec 2, 2022 at 14:43
  • @Tetsujin Files and folders have to be the other side of the dividing line from apps.
    – benwiggy
    Dec 2, 2022 at 14:50
  • @benwiggy Is this an answer to the question, or to Tetsujin's comment beneath the question?
    – nohillside
    Dec 2, 2022 at 16:04
  • I have two dividers, I just dragged the thing around for a while & it didn't seem interested - until I tried again right next to the Trash icon, then it expanded welcomingly.
    – Tetsujin
    Dec 2, 2022 at 17:07
  • @nohillside Answers are answers; comments are comments.
    – benwiggy
    Dec 2, 2022 at 17:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .