1

Monterey 12.3.1 on a 2020 M1 MBA

Issue

I run a streaming client in a Terminal under VS Code. It's ok if the screens go off through the timer when I step away, but I want WiFi and the computer to continue running. WiFi should stay up indefinitely under Power Adapter.

Battery Settings

There's only a slider for "Turn display off after:". There used to be a "Turn computer off after:" setting (on never would prevent WiFi from shutting off), but it's no longer there.

Is there a way to allow for the screens (MBA + external monitor) to turn off with the MacOS timer, but otherwise have the MBA continue running (no WiFi interruptions)?

2 Answers 2

1

Control shift eject (or F12 if your keyboard lacks a media eject key or power button) sleeps the display(s) immediately which turns off the display and backlight. The system will stay running after pressing this.

Control–Shift–Power button* or Control–Shift–Media Eject : Put your displays to sleep. The * indicates that Touch ID does not work for this so you’ll need F12 or a keyboard or to use a hot corner possibly.

Tackling the never sleep is well covered with command line tools if you need more control than the energy preferences allow.

3
  • I'm not trying to actively send it to sleep. When I walk away, I want MacOS to sleep the screen using its timer, but leave WiFi and any processes to continue running.
    – kfmfe04
    Apr 27, 2022 at 5:26
  • The machine itself does not sleep when you sleep the display. They are separate events. @kfmfe04 thanks for pointing out that I linked to the wrong related posts. I fixed what with an edit.
    – bmike
    Apr 27, 2022 at 10:50
  • Battery->Power Adapter->Prevent your Mac from automatically sleeping when the display is off
    – getsuha
    Jun 16, 2022 at 8:43
1

Amphetamine ( https://apps.apple.com/gb/app/amphetamine/id937984704 ) supports the behaviour you are looking for and has many more options as well.

It is free and for me it was the best solution to the problem since it doesn't require any change in my behaviour nor to remember to do anything. Create a session with indefinite duration and check the checkbox "Allow display sleep" .

You can also set it up to automatically launch at login and to automatically start your default session on launch.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .