0

I am trying to boot Kali Linux from my late 2020 M1 MacBook Air with macOS Monterey. I tried to boot an x64 Kali image on an M1 system, but encountered the following problem.

I used both Balena Etcher and Terminal to create my bootable USB drive and both showed success. So, I shut down my computer and press the power button until the boot menu appears.

At this point, I am getting the options: Macintosh HD, Options with the symbol of settings, but no USB drive that I named Kali. After that, I press on the Macintosh HD, because I do not want to recover my Mac. When my computer opens and immediately displays a popup shows with the warning/error message "The disk you attached was not readable by this computer".

Any ideas what the problem is and how can I fix it?

3
  • What is the name of the file you downloaded from Kali? Mar 12 at 18:21
  • So, from looking at your answer, you tried to boot an x64 Kali image on an M1 system? Might have helped to mention that in the question :-)
    – nohillside
    Mar 17 at 13:59
  • Yes, that's what I did. Mar 17 at 18:17

1 Answer 1

0

I looked for information on the Apple Discussions site, and I received this answer:

Kali on the Apple M1

As we announced in Kali 2021.1 we supported installing Kali Linux on Parallels on Apple Silicon Macs, well with 2021.4, we now also support it on the VMware Fusion Public Tech Preview thanks to the 5.14 kernel having the modules needed for the virtual GPU used. We also have updated the open-vm-tools package, and Kali’s installer will automatically detect if you are installing under VMware and install the open-vm-tools-desktoppackage, which should allow you to change the resolution out of the box. As a reminder, this is still a preview from VMware, so there may be some rough edges. There is no extra documentation for this because the installation process is the same as VMWare on 64-bit and 32-bit Intel systems, just using the arm64 ISO. As a reminder, virtual machines on Apple Silicon are still limited to arm64 architecture only.

So, I gave up running it from the USB drive, after I tried several USB drives, and ran it on VMware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .