0

I created a live USB on a SanDisk 32GB flash using Kali Linux live ISO and Balena Etcher software (I also tried dd) but the USB won't show up in the boot drive selector.

Startup menu

Startup menu

Kali ISO

Kali ISO

usb EFI in finder

USB EFI

Output from diskutil command

diskutil list

diskutil list

I don't want to use a VM

3
  • 3
    I highly doubt there is any support for booting from USB on apple silicon as of now, and even if you managed to boot into the installed Kali, do not expect almost anything to work since there is no drivers for things like WiFi or Bluetooth to work. VM is most likely your best bet if you want Kali on mac. Besides, who would ever want a pen test OS to be running on bare metal?? if you just want linux experience, consider Asahi Linux which do support bare metal install on M1 mac (to a certain extent) and is based on Arch Linux so that's more epic Mar 28, 2022 at 7:43
  • Did you ever manage to get kali live to work on M1?
    – Kodeeo
    Feb 14 at 22:41

2 Answers 2

1

For M1 Mac please follow the below steps to go into the startup options:

  1. Turn off your Mac via the Apple logo and Shut Down.
  2. Press the on/off button and hold it down.
  3. Once the Apple logo appears, press and hold the on/off button again until you see Loading Startup Options.

Took me a couple of attempts before it loaded up.

-2

You have to enable security boot options first :

  1. Turn on your Mac, then press and hold Command (⌘)-R immediately after you see the Apple logo. Your Mac starts up from macOS Recovery.

  2. When you're asked to select a user you know the password for, select the user, click Next, then enter their administrator password.

  3. When you see the macOS utilities window, choose Utilities > Startup Security Utility from the menu bar.

  4. When you're asked to authenticate, click Enter macOS Password, then choose an administrator account and enter its password.

  5. Tick "No security" in Secure Boot option

  6. Tick "Allow booting from external or removable media" options

  7. Reboot while pressing the options key

Lemme know if ot works :)

5
  • This does not work on Apple Silicon.
    – nohillside
    Feb 9, 2023 at 20:20
  • Worked on mine.
    – Johann8724
    Feb 10, 2023 at 21:03
  • Which Mac model do you use?
    – nohillside
    Feb 10, 2023 at 21:13
  • Mac Mini M1 2020
    – Johann8724
    Feb 11, 2023 at 22:05
  • Just tried with mine, Cmd-R does nothing (which matches the documentation which mentions pressing the start button at the back to get to Recovery). Wonder what's going on on your Mac here :-)
    – nohillside
    Feb 12, 2023 at 19:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .