The cause of my issue seems straightforward: I enabled BitLocker on a MacBook Pro, early 2015 model which out-of-the-factory is only available with an Intel processor. That having been said - and someone, anyone can correct me if or when I'm wrong? - Bitlocker could not be implemented through the TPM, presumably because my Windows OS operates as the slave volume and alterations with the TPM are impossible given File Vault is installed on the MacOS partition. Or, alternately, neither of the partitions interact, beyond the Bootcamp Assistant.

I am unaware of whether or not the TPM comes factory installed on a MacBook Intel processor though, of course, the inverse is true for most modern if not all factory-shipped Windows machine. I am mentioning the TPM assuming that it's somehow involved with my inability to push updates - though this could be an irrelevant. Just a shot in the dark.

Either way, since installing BitLocker, if either by coincidence or cause, I have been unable to install the next available Windows update; I believe it's stuck back on a failed execution step in the process of an attempted upgrade to 20H2. I doubt the update version is relevant though. I have attempted the update using PowerShell, thinking it will offer a surefire method given it operates with more elevated privilege or system control, but PowerShell failed on the update as well. I have also attempted the update in Safe Mode, which also fails.

If logs are needed for proper analysis and a consequent solution, please advise which output is needed from the given log or logs and I will post it accordingly. I have little-to-no interest in removing BitLocker before an additional upgrade attempt. For that reason, any advice involving that step may not be the best here unless it's the one-and-only solution.

  • Well, I can't answer that, haha. It's stuck in 2020, I guess? Likely, I installed an earlier image at one point. Either way, I believe it was updating with a frequently high success rate - that is up until I implemented BitLocker. I suspect that Apple just doesn't care about any given desire for security that a Windows user has if or when the primary use happens on the Windows Boot Camp partition. Commented Jan 2, 2022 at 10:02
  • ... It looks like it's even successfully downloaded all of the files for the upgrade to the next version but it won't install them on reboot. I'll keep everyone posted. For now, anyway, the problem remains unresolved. This should be a basic help-desk desktop support problem but I think it's tied into the security modules which makes it all the more complex. Commented Jan 2, 2022 at 10:08
  • Okay, so I already said in my post that I'm disinterested in suspending Bitlocker. Per my post above, "I have little-to-no interest in removing BitLocker before an additional upgrade attempt. For that reason, any advice involving that step may not be the best here unless it's the one-and-only solution." Yes, Mr. Anderson, removing Bitlocker would probably do the trick but that would be a short-term fix to a long-term problem. The sole goal is to update Windows in continuity with Bitlocker running without having to turn Bitlocker on or off each time, which would pose somewhat of a hassle. Commented Jan 2, 2022 at 14:24
  • Mac's don't have a tpm, you can only enable bitlocker by suppressing the check.
    – lx07
    Commented Jan 19, 2022 at 20:47
  • They don't have a TPM ... Yes, I figured that out when I set up Bitlocker. There's also a separate problem which is preventing me from enabling virtualization effectively. This is more appropriate for another unique question. Suffice it to say, Bootcamp is not a one-size-fits-all solution for those looking to get everything out of their Mac while still having the native OS. Also, the newer Macs with the M1 chips won't run Bootcamp, which I find lame. Commented Jan 19, 2022 at 22:09

1 Answer 1


I found the solution to this however random. I did a few things though I can't remember in what chronological order. For one, I corrupted my Windows partition on Bootcamp by running a script off of Github which claimed to offer a better alternative to the third-party driver: Trackpad++. I nearly had to reinstall Windows but I did the obvious thing, given it was almost impossible to reinstall the Mac drivers for Windows, and used a wired mouse to navigate the OS.

So, with corded mouse in hand, as the trackpad wouldn't work at all - given the MacBook driver was shot - I simply reinstalled Trackpad++ but deleted the part of the program which runs the native control panel: essentially bloatware trying to get me to pay for stuff I don't need. I also ran - either before or after - the sfc /scannow command on the command prompt.

I got curious as to whether or not the scan could have or would have fixed the update issue with failed patches. Oh, yes, and I may have ran the DISM command syntax with the "RestoreHealth" switch. I also booted Windows into safe mode, which is tricky on Bootcamp. If anyone wants to know how to do that, I'll explain. Long story short, one of those steps fixed it or a combination more than one did the trick.

The moral of the story? Windows on Bootcamp can be successfully updated when Bitlocker is installed. The OS gets buggy and the drivers don't like it, along with the encryption, but it can be done if the end user implements enough creative tech savvy in the process.

All things considered, I think this topic can be closed and whoever is moderating this topic can do so if desired. Any comments before this close out, are more than welcome. I'm eager to hear a theoretical explanation of why or how any of these steps worked


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .