0

I have a Windows 7 .iso I always use for BootCamp installations. It works.

I have a MacBook Pro Retina 15" Mid-2014, and I have installed Windows 7 in it successfully in the past. Throughout the latest months, for a number of reasons I have uninstalled the partition, and installed Windows again, and uninstalled again, and so on.

Today I currently don't have Windows installed, and decided to do so. The installation was apparently successful as always: BootCamp partitioned around 40GB for Windows, downloaded the Support Software, booted from USB flashdrive, and then it restarted (as always).

But then, when my Mac tries to boot into Windows, it doesn't seem to work anymore. I am met with a black screen and the following text displays:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

  1. Insert your Windows installation disc and restart your computer.
  2. Choose your language settings, and then click "Next."
  3. Click "Repair your computer".

If you do not have this disct, contact your system administrator or computer manufacturer for assistance.

File: \windows\system32\drivers\AppleSSD.sys

Status: 0xc0000428

Info: Windows cannot verify the digital signature of this file.

Now, something different must have happened compared to all the many times I installed Windows on BootCamp... I do have an idea. The last installation was removed by deleting the partition using Disk Utility (instead of using BootCamp assistant). That's the only difference I can think of.

I have read that I could delete the AppleSSD file. And I did. But now many things seem to be wrong: for starters, the OS doesn't seem to be able to connect to my Wireless network (so it seems like the drivers were not properly installed).

What should I do? I deleted the partition and tried again, but the same occurs. A friend has another .iso I borrowed, but it didn't work either.

The problem can't be with my .iso - I've used it so many times before. It works fine. Something must be wrong somewhere else.

I am using OSX Yosemite.


Edit

As requested, I deleted the Windows partition and ran diskutil list:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            250.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s4

Then sudo gpt -r show /dev/disk0:

      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  488555536      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  488965176    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  490234712          7         
  490234719         32         Sec GPT table
  490234751          1         Sec GPT header

And sudo fdisk /dev/disk0:

Disk: /dev/disk0    geometry: 30515/255/63 [490234752 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -  490234751] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
  • My guess would be you have other hidden small partitions on your disk that need to be deleted before installing Windows. Remove Windows then post the output from the following commands: diskutil list, sudo gpt -r show /dev/disk0 and sudo fdisk /dev/disk0. None of these commands will change your computer. Some commands may ask for your login password. This is normal. – David Anderson Aug 24 '15 at 7:38
  • @DavidAnderson I've posted the output now. Thanks. – Omega Aug 24 '15 at 8:03
  • The disk partitions look correct. When you boot from the USB flash drive, I assume you are given two options. 1) Windows and 2) EFI boot. If so, which do you choose? – David Anderson Aug 24 '15 at 8:15
  • @DavidAnderson actually I don't see an EFI option. I only see "Macintosh", "Recovery" and "Windows". I'm not even sure what EFI is supposed to be. – Omega Aug 24 '15 at 8:46
  • Your answer is OK. You are doing a BIOS/MBR install, which is expected for Windows 7 on a Mac. I ask because my newest Mac is 2011 and I boot from a DVD. I don't know how a USB boot looks. When does the problem you describe occur? While installing windows? Afterwards when booting Windows, but before installing the Boot Camp drivers? Or, after installing the Boot Camp drivers. – David Anderson Aug 24 '15 at 9:01
2

This basically is a repost of the following sites:
get "appleSSD.sys" error when installing windows 7 through bootcamp and
bootcamp - appleSSD.sys digital signature can not be verified

Looks like there are problems with Boot Camp Support Software (BCSS) being downloaded from Apple. Here is a solution:

  1. Download an older version of the BCSS for your Mac. See System requirements to install Windows 7 and earlier on your Mac using Boot Camp. In your case, the software can be found at Boot Camp Support Software 5.1.5621.
  2. Using Boot Camp Assistant, prepare the USB flash drive. Select the first two items and prepare the disk.
  3. Quit Boot Camp Assistant.
  4. Using the Finder, move the $WinPEDriver$ and BootCamp folders from the USB flash drive to the Trash. Empty the Trash.
  5. Using the Finder, copy the $WinPEDriver$ and BootCamp folder from the BCSS to your flash drive.
  6. Reopen Boot Camp Assistant and select only the third option, install Windows.

An explanation regarding the purpose of these folders can be found at Limitations of $WinPeDriver$ when used in conjunction with other driver injection methods.

  • I am not currently setup in a way that i can verify my answer. So if it works or needs changes, please post a comment. Or at least post your version of the answer. – David Anderson Aug 24 '15 at 11:33
  • This got me past the user-creation and now I am in the desktop. It seems the drivers are not properly installed because I can't find any wifi network at all, or use any USB device. I managed to copy both $WinPEDriver$ and BootCamp files into the Desktop, but executing setup.exe prompts me to This version of BootCamp is not compatible with this computer model. I have tried doing this with both the software downloaded from the link you provided as well as the software downloaded from Boot Camp assistant. – Omega Aug 26 '15 at 7:16
  • Apple modified their Boot Camp web pages when they updated for Widnows 10. These pages appear to have lots of errors. I am not going to try to explain how I came to this next conclusion, mostly because I am only half convinced I may be right. The correct Boot Camp Support Software for your Mac may be version 5.1.5640. Please download from here and try it. – David Anderson Aug 26 '15 at 10:14
1

I had experienced the same problem after resetting my Macbook Air and then attempting to re-install W7 in Bootcamp. The default bootcamp assistant download returns an error message, so I had to download an older version which did boot the W7 desktop, but without drivers for sound and wifi. I did however have USB functionality, from this I was able to insert the USB stick with the BCSS on it to locate the Apple drivers set up. The sequence is 'bootcamp' > 'set-up'. This manual fix worked fine for me. Clearly there is an issue with bootcamp arising from the W10 calibration in bootcamp which requires fixing as its causing a lot of confusion for those of us with a copy of W7. Hope this helps.

1

All, I just wanted to say thanks for the recommended solution - getting BCSS 5.1.5621 helped me also (link here https://support.apple.com/kb/DL1720?locale=en_US) - I have MacBook Pro Mid-2012 (non-Retina).

The only other thing I'd like to add to keep this process even simpler, is that after you've downloaded the older versions of BCSS, if you already got Windows installed (it should show up in Finder as a separate drive), then simply replace the BCSS folders/files with the older version, then do a reboot WITH your USB Windows ISO flash/external drive (press ALT during startup and select the USB drive). This will automatically take you back to installing Windows. You can then reselect option to format the partition, and voila! all other steps will remain same and it should proceed smoothly (that's what worked for me).

I mention above only because it will save you a ton of time, no need to relaunch Boot Camp Assistant, writing Windows to USB, then removing/installing Windows, then having to reformat the partition to NTFS….you get my point. Good luck!

0

Here is a quick update. Currently I am running Version 10.11.2 on a 15″ mid 2014 MacBook Pro. Using an external CD-ROM drive with Windows 7. I downloaded the Boot Camp Support Software (BCSS) and put it on a flash drive. I quickly went through the process only to find myself with an error saying "Windows cannot verify the digital signature for this file" error. If you are confused where to start, start here: http://www.apple.com/support/bootcamp/. Make sure before you start anything you have the right BCSS downloaded. Each Mac can be a bit different. See this page and scroll down: https://support.apple.com/kb/HT205016. As long as you have the right BCSS and you have the ISO on a flash/external drive or disk you should be good. If you receive an error after installing Windows there is a good chance it is the wrong BCSS. In this case you need to install the most current one or if this does not work use an older version of BCSS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .