0

Yesterday. I cloned my hard drive to my SSD for use. One of the essential apps I need to use is EVKey which works fine with no issue before.

After I boot up the SSD, I notice that I am not able to add it to Preference which is needed for it to work at all. This app works out of the box back on my Mojave installation on the hard drive so I'm confused on what happened.

I tried all tcc reset commands but none of them work, I even disabled SIP which then everything works but it immediately broke after I enabled SIP back. I tried to find the TCC.db file but such file doesn't exist on my mac. Can somebody help me with this? I'm confused as hell

P/s: I'm on a mid-2012 MBP with Mojave 10.16.6

5
  • Does this answer your question? System Preferences can't alter Files and Folders
    – mmmmmm
    Dec 27, 2021 at 15:00
  • @mmmmmm no it doesn't sadly. I would prefer not downgrading to High Sierra or updating to Catalina. Plus, my Preference menu is just empty with no apps in it, no matter how many time I try to add apps
    – schlong
    Dec 27, 2021 at 15:04
  • Sorry about the text - it is a hard coded one from Stack Exchange - I just meant it looks like the same issue I had and so an answer if we can get one should answer both of our issues.
    – mmmmmm
    Dec 27, 2021 at 15:35
  • What did you clone it with?
    – Tetsujin
    Dec 27, 2021 at 17:07
  • @Tetsujin CCC (Carbon Copy Cloner 5)
    – schlong
    Dec 28, 2021 at 0:01

1 Answer 1

0

I'm not even really sure what I did. I tried to reinstall macOS on my SSD but I forgot to wipe the drive. Though reinstalling it somehow "patches" my Mojave installation in a sense? I'm not sure but everything is working accordingly now and I can use Accessibility with no issues at all (SIP Enabled as it should be of course).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .