1

I decided to reinstall Mojave onto a mid-2012 MacBook Pro that I purchased second hand in June 2020 & modified some of the internals of*. I have a lot of files from previous backups of files as well as from the last time I used Windows in 2018, & it was beginning to get a bit glitchy. While I did follow the instructions on the Apple website to make a bootable USB stick with Mojave on it with Terminal, I don’t think that I formatted the USB correctly.

It also gives me an error that says “This copy of the Install macOS Mojave application is damaged and can’t be used to install MacOS.”

The previous owner had installed Catalina onto it, but I’m also an artist who needs 32-bit app support. Last year, I managed to get a USB stick with Mojave on it working (I currently don’t have access to it), but I’m beginning to think that’s why I can’t reinstall Mojave.

Terminal tells me it’s on Bash version 3.2. I’ve tried internet recovery (which has never worked with this machine), & changing the date to some time not long after Mojave’s original release date.

I’m at a complete loss.

*I replaced the original, failing 750GB HDD with a 2TB SSD; replaced broken super-drive with a SATA adaptor & a 1TB SSD; increased RAM to 16GB; replaced depleted battery with fresh one. I didn’t buy them all at once.

7
  • 1
    Sometimes that error is an expired certificate. Try setting the clock back a year or 3 and re-try the install. May 18, 2021 at 22:47
  • What's the brand of USB stick? May 19, 2021 at 4:14
  • @SteveChambers I tried going back to not long after my machine was made, & it didn't work. May 19, 2021 at 6:35
  • @Harper-ReinstateMonica It was just a generic one I picked up new from the shop at work. May 19, 2021 at 6:36
  • NKA_Krokodil, I have edited out your update answer and removed solved from the title as that is not how things are done here. Please post an answer containing what you did you solve your issue. Not only can you self-answer your own question, you can also mark it as the accepted answer. Thanks. May 19, 2021 at 6:53

1 Answer 1

2

I managed to solve it myself by going into recovery mode, trying but failing to install Mojave, then going to Disk Utility, view > show all volumes, having some files that said something to the effect of “EAS install files” (I can’t quite remember the name) burned to one of the internal SSDs. I then exited Disk Utility, went Apple Logo > Start-up Disk, & booted it up from one of the SSDs.

It then reinstalled fine, but it took about 6 hours in total.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .