I bought a mid 2011 Mac Mini mit dedicated graphic card along with the iFixit dual hard-drive kit and a OWC Mercury 6G SSD.

After I installed the ssd into the Mac Mini with as second hard drive, the boot time of Lion on the factory hdd increased to about 4-5 minutes. On login, a dialog appears, stating that a uninitialized hard drive was found. So I tried to partition the SSD with GUID partitioning scheme and one HFS+ Journaled partition. The partitioning process was stuck at about 50% and failes after about 2 minutes with a posix input/output error.

Formatting the SSD with diskutil from terminal succeeded once, but after a reboot the partitioning scheme was set back to master boot record acording to disk utility. Also the same unintialized disk dialog appeared again.

In the system information tool the ssd is recognized with correct values and also 6g sata speed.

On the system console tool, a kernel: I/O error appears everytime I try to format or partition the ssd.

I also tried installing Lion directly on the SSD, but installation failes somewhere around 10 minutes after starting the installation.

So my question is: Is this a bad SSD and I have to return it to OWC, or is there some thing I have forgotten to make the SSD useable as system hard-drive. I want to avoid sending the SSD back to OWC before I try every possible fix, because living in Germany, sending a package to USA is always a hassle, because of duty and shipping cost.


First thing I would do is contact OWC support. They have an excellent support team. I suspect that you might need to update the SSD's firmware.



I solved the problem by switching the SATA ports of the hard-drive with the SSD. Maybe the iFixit dual hard-drive kit SATA adapter has problems with SATA3 speed disks. Now everything works fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .