0

This disk that used to work isn't recognized at all now.

My Mac (mactel) got bricked because I was fiddling with triple boot setups, and at one point I made Mac unbootable. (Will describe what happened later in this question if interested.)

For several reasons, I used fdisk on Linux (Ubuntu on flash drive) to wipe everything off from that internal disk by applying the GPT scheme to the disk. The disk is totally visible as /dev/nvme0n1 on Ubuntu. However it's not on macOS's recovery mode.

When I go into recovery mode (did both Command + R and Option + Command + R but it's always El Capitan for some reasons), Disk Utility GUI won't show anything besides "Apple disk image Media". (It will show USB flash drive if I plugged them in.) If I move onto CLI version of it, diskutil list will return something like this:

/dev/disk0 (disk image):
    #:                      TYPE NAME                      SIZE       IDENTIFIER
    0:     GUID_partition_scheme                          +2.1 GB     disk0
    1:                 Apple_HFS OS X Base System          2.0 GB     disk0s
/dev/disk1 (disk image):
    #:                      TYPE NAME                      SIZE       IDENTIFIER
    0:                           untitled                 +5.2 MB     disk1
# ..
# other 11 disks with similar stuff sized in between 524.3KB (half of those) to 6.3MB
# ..
/dev/disk13 (disk image):
    #:                      TYPE NAME                      SIZE       IDENTIFIER
    0:                           untitled                 +6.3 MB     disk13

Whereas I expect something as follows:

/dev/disk0 (internal, physical):
    #:                      TYPE NAME                      SIZE       IDENTIFIER
    0:     GUID_partition_scheme                          +1.0 TB     disk0
/dev/disk1 (disk image):
    #:                      TYPE NAME                      SIZE       IDENTIFIER
    0:     GUID_partition_scheme                          +2.1 GB     disk1
    1:                 Apple_HFS OS X Base System          2.0 GB     disk1s

ls /dev would not show much interesting output, and there certainly are nothing like nvme0.

Are there more cleaning up to do on the disk (such as removing snapshots from APFS? Are these 13 disk images those snapshots from the disk somehow)??


And here is it for post mortem, more specifics for what this is and how it's got bricked.

Hardware

How it got bricked

Short version:

I was trying triple boot setup, which was unsuccessful and tried to start it over by undoing it by asking macOS Boot Camp Assistant to wipe them off, which returned the error, leaving Linux partitions un-wiped. Now it won't boot up.

Long version:

Physical upgrade (Successful)

  1. Swapped with new 1TB SSD, formatted with APFS (I think), installed macOS from Time Machine backup. No hiccups, perfect experience.

Dual-boot (Successful)

  1. Installed Windows 10 with Boot Camp Assistant, just as Apple recommends. Left 500GB for Mac and the rest 500GB for Windows. Again, works like a charm as expected, no hiccups.

Triple-boot (Failed)

  1. Boot into Windows and use Disk Management to shrink the Windows partition. Now it's [500GB: macOS] + [250GB: Windows] + [250GB: unallocated]. So far it boots to both OS with no problem (although Mac's Disk Utility GUI might have not be happy with this, but I don't remember.)
  2. Installed rEFInd, so now it boots into rEFInd menu, and shows both Mac/Windows options, as expected. So far so good.
  3. (Try installing Fedora and I couldn't see no success, so I gave up. Wiped off new partition - and everything works just like before.)
  4. Installed Ubuntu but it didn't boot into Ubuntu although the rEFInd menu shows the Ubuntu icon (as it did install /boot/efi into existing EFI partition). Now Windows won't boot.
  5. Reinstalled rEFInd, and now Ubuntu works, but Windows does not.
  6. Now it boots into rEFInd menu, and macOS and Ubuntu works, but Windows does not. I couldn't figure the fix so I decided to start over with simple dual boot setup the way Apple supports.

Starting over (Failed)

  1. Asked Boot Camp Assistant to wipe current Boot Camp. Took a few minutes doing this and that, and it threw some error (which I didn't take memo regrettably). Disk Utility GUI was showing something glitchy (which I didn't take memo neither), and it didn't wipe Linux partitions.
  2. Booted into Linux (Ubuntu) from USB flashdrive, and used fdisk to apply new GPT to the disk.

And now diskutil list won't recognize the physical disk.

3
  • What model is the SSD. The SSD may require a version of macOS that is newer than El Capitan. – David Anderson May 14 at 11:21
  • Ubuntu and Windows have conflicts when using the same EFI partition for the boot files. The Windows boot files overwritten by installing Ubuntu can be restored without having to reinstall Windows. – David Anderson May 14 at 11:38
  • @DavidAnderson I had back up for the whole EFI partition and fiddling back and forth to no avail, but well, that's a bummer to hear haha. I should've stayed that way for longer. SSD model is linked in the article. Just noticed it said it has to be High Sierra or higher, so I figured that perhaps there's the problem (driver?). I have a separate High Sierra machine so I'll maybe use target disk mode or something. Thanks for hints! – Iorippi May 14 at 14:15
0

That particular disk that I was using had an OS requirement in description as follows:

Requires Mac OS X 10.13 High Sierra or Higher BEFORE and AFTER installation

Thus the answer was that I needed Recovery Mode of newer macOS version for that disk to be able to detected. If anyone had a similar problem, you should check the requirement for that particular model also.


What I did

I did the following firstly, but you may not need them.

  1. Turn off firmware password
  2. NVRAM reset

Then I booted Mac into Recovery Mode with Option + Command + R, typed WiFi credentials in, and it automatically updated the Recovery Mode into the latest version (Big Sur).

Proceed to open the Disk Utility, and now it recognizes the disk!

Format the disk and now the latest OS is ready to be installed, and it should work throughly as I did.

But I had to repeat this umpteenth times. If this didn't work in first try, please read follows.


Maybe don't give up, and keep trying!

Now the very odd part was that, I did all that and the result was either

  • Get "-2003F" error, and full stop there.
  • Boot into Recovery Mode but the old version of Mac (El Capitan in my case).

Internet connection was reasonably stable (the one for my home that has very conventional setup, no particular firewall fiddling on any port). (I thought Ethernet dongle helps, but apparently it has to be Apple's dongle so perhaps that try had no use.)

Another thing that seemed rather odd is that, Apple's official Mac startup key combinations help page does not make distinction between Option + Command + R and Command + R anymore, which they used to back in the day. Although both of the combinations seemed as though they did try to connect to internet anyways (as it had globe icon), I think it's worth trying for the one with Option key especially if you had machine that are rather old like mine.

Anyhow, I swear I had it for more than 10 times for each, but now it worked. Only difference was the time I tried, which was early afternoon, and I got it through around 11PM, so probably that was about the slow internet connection.

If you were using public WiFi, it might be better to find another stable network until it boots into the latest version of Recovery Mode (of course that is as long as your Mac supports the version later than what you already have.)


Other suggestions

Here's few other options that may work, though I have tested none of these.

Booting from another disk that has macOS of later version installed.

Target Disk mode

Needs cable to connect the two Macs, such as thunderbolt cable

  1. Use other updated machine in target disk mode and connect to the machine with the unformatted disk.
  2. Boot into Startup Manager to boot into the updated version of macOS. Log in and use Disk Utility.

Physically attach the disk

Needs the other Mac to be able to detach internal disk, and an adapter

  1. Take out the disk with new macOS, use adapter (such like SATA to USB adapter) to connect the disk as USB peripheral to the machine.
  2. Boot into Startup Manager to choose that attached drive into the updated version of macOS.

Bypass the driver problem with adapter

Needs an adapter

  1. Use adapter to connect the disk as peripheral (such as NVMe to USB adapter, etc) so the old OS can recognize it as USB drive.
  2. Boot into Recovery Mode and now it should be able to see the drive in Disk Utility.

Credit: @DavidAnderson: Thanks for a little hint and advice!

6
  • Now you might want to ask how to do a triple boot. – David Anderson May 14 at 17:54
  • @DavidAnderson Haha yes I surely do! Seems like this (apple.stackexchange.com/a/253351/74187) would do for me, so I'll keep the copy of EFI partition as I proceed and learn what how they works step by step for starter. – Iorippi May 15 at 1:56
  • Ubuntu and Windows both store their version of bootx64.efi in the \EFI\Boot folder in the EFI partition. For Windows, \EFI\Boot\bootx64.efi is the same file as \EFI\Microsoft\Boot\bootmgfw.efi. Some possible solutions: 1) Install a GRUBless Ubuntu. 2) Move GRUB to a another EFI partition. 3) Add a manual entry of Windows in the refind.conf file. – David Anderson May 15 at 6:55
  • @DavidAnderson Thanks for another tips! You're really helping me into the directions. I've just done a bit of research on booting process and now I understand the 2nd option! (apple.stackexchange.com/a/235505/74187) Perhaps I'll go that route, but I'll study the first option before proceeding. Is it "EFISTUB booting"? – Iorippi May 15 at 7:31
  • Some parts of the answer you have linked to are no longer true. For example, the current Ubuntu does create the \EFI\Boot\bootx64.efi file. This is the same as the \EFI\ubuntu\shimx64.efi file. The problem with older answers is an answer may not apply to the model Mac your are using and/or the versions of the software may have been updated. – David Anderson May 15 at 9:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .