1

When I first got my MacBook Pro, I installed Windows 7 via Boot Camp.

A couple months later I wanted to install Ubuntu and have a triple boot. I followed this tutorial: triple-boot

After I finished following the steps in the tutorial, Windows would not boot (everything else worked fine), so I opened up Disk Utility and decided to remove the Windows partition (because it was setup with Boot Camp). Doing this only created a huge free space where my Windows partition used to be.

Now anything I try to do in Disk Utility displays the error: "Mediakit reports no such partition", even when trying to split up my Mac HD.

How to fix this?

0

Have you tried to format the free space as FAT32 and use bootcamp assistant to remove the space? Possible to also format the space as NTFS with your Windows disk and try removing it with bootcamp utility.

Otherwise as Gauzy said, backup your data on OSX and Ubuntu and format the drive =(.

Bootcamp partitions have to be removed via Bootcamp Assistant otherwise it causes problems.

  • I had to delete my linux partition but it worked! Thanks so much! – GeeGoldz Aug 21 '11 at 19:45
1

The easiest way I can think of would be to clone the Mac partition and the Ubuntu partition, then repartition the drive, and restore those partitions back.

I don't have any experience with using rEFIt, but I can't think of a reason why this wouldn't work.

  • I tried what jacklar said but it didn't work =( I feared I would have to do this – GeeGoldz Aug 21 '11 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .