1

I'm using my first Mac ever, a recently acquired Macbook Air with the M1 chip. It has the latest version of Big Sur (11.3 (20E232)).

I was having issues with my existing thumb drives, most of them formatted with NTFS. When connected to the macbook nothing would pop up, and I couldn't see the drive even on the disk utility. Nothing, not even grayed out.

After digging a bit on google I noticed that I needed some third party software to make it work with NTFS, but there was an alternative to format it with ExFAT. Tried that, no luck. No matter what block size I choose, it won't pop up when connected to the mac.

I bought a new thumb drive that says it works right out of the box, a sandisk ultra dual drive usb type-c. Tried connecting it and again: nothing pops up. Tried on my windows machine and it works right away. It was formatted as ExFat already so I'm a little puzzle on how to resolve this.

If I go to the system report, under Hardware -> USB I see there's a device connected:

system report

Do I need to do anything else to make it appear?

diskutil list

me@MacBook-Air ~ % diskutil list
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         251.0 GB   disk0
   1:             Apple_APFS_ISC ⁨⁩                        524.3 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk3⁩         245.1 GB   disk0s2
   3:        Apple_APFS_Recovery ⁨⁩                        5.4 GB     disk0s3

/dev/disk3 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +245.1 GB   disk3
                                 Physical Store disk0s2
   1:                APFS Volume ⁨Macintosh HD⁩            15.4 GB    disk3s1
   2:              APFS Snapshot ⁨com.apple.os.update-...⁩ 15.4 GB    disk3s1s1
   3:                APFS Volume ⁨Preboot⁩                 310.5 MB   disk3s2
   4:                APFS Volume ⁨Recovery⁩                1.1 GB     disk3s3
   5:                APFS Volume ⁨Data⁩                    180.1 GB   disk3s5
   6:                APFS Volume ⁨VM⁩                      1.1 GB     disk3s6

system_profiler SPUSBDataType

me@MacBook-Air ~ % system_profiler SPUSBDataType
USB:

    USB 3.1 Bus:

      Host Controller Driver: AppleT8103USBXHCI

    USB 3.1 Bus:

      Host Controller Driver: AppleT8103USBXHCI

         SanDisk 3.2Gen1:

          Product ID: 0x5595
          Vendor ID: 0x0781  (SanDisk Corporation)
          Version: 1.00
          Serial Number: xxxxxxxxxxxxx
          Speed: Up to 5 Gb/s
          Manufacturer:  USB
          Location ID: 0x01200000 / 1
          Current Available (mA): 900
          Current Required (mA): 896
          Extra Operating Current (mA): 0

me@MacBook-Air ~ % 
4
  • In Disk Utility, make sure you have View -> Show All Devices enabled (command-2).
    – Gilby
    May 1, 2021 at 0:26
  • @Gilby I've just added the output of diskutil list. Tried with your suggestion also with no luck.
    – Tute
    May 1, 2021 at 0:34
  • At this point, I pass. Sorry.
    – Gilby
    May 1, 2021 at 0:47
  • 1
    A lot of people seem to be having issues with USB drives under Big Sur. I've seeing the exact same issue you are with an external HDD. Shows under Device Tree, but basically nowhere else. VMware Fusion also can see it, but the storage is also not available inside windows VMs either. Apple has been completely silent on this issue for some reason. As far as I can tell after spending half a day on this issue, there's currently no work around. We're all just out of luck.
    – Mordred
    May 4, 2021 at 19:25

1 Answer 1

1

Don't hesitate to force a little to connect this key. I noticed that on MBA M1 some USB-C / Thunderbolt devices were a bit "complicated" to plug in and sometimes were not fully connected.

2
  • I've tried this with no luck
    – Tute
    May 5, 2021 at 23:26
  • 1
    Damned. Can you try boot your Mac in Safe Mode and test this way : support.apple.com/guide/mac-help/…
    – user415185
    May 6, 2021 at 4:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .