When clicking on the link to download the installer for macOS Mojave from the App Store, Google Chrome is giving me an HTTP error 403 "Access Denied", and Safari is just showing a blank page.

Here's the link: https://apps.apple.com/us/app/macos-mojave/id1398502828?mt=12

I've tried clearing my cookies and cache, as well as signing out and back in to my Apple account.

  • App Store links should work from Safari, but not necessarily from 3rd party browsers. That should then auto-launch the App Store. Not sure why it doesn't in your case; maybe if Chrome is set as default browser it changes the behaviour. Glad you managed to get it working anyway :)
    – Tetsujin
    Commented Apr 29, 2021 at 5:55

1 Answer 1


Forcing the link to open in the Mac App Store app solved the problem for me. Just run this command in Terminal:

open -a App\ Store https://apps.apple.com/us/app/macos-mojave/id1398502828?mt=12

Since the App Store app opens the link just fine, the problem must be something with the browser.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .