1

I'm trying to install MacOS Mojave on my computer (MacBook Pro running Catalina). When I open the link to download the installer, I am lead to a blank page with the title "@@softwareName on the App Store." The link I'm using is the one given in this StackExchange answer:

https://apps.apple.com/gb/app/macos-mojave/id1398502828

I am using Safari and have my default browser set to Safari, though I've also tried Firefox and Chrome with no success. What is causing this problem, and how can I fix or work around it?

2 Answers 2

1

Apparently, the link is broken on PC right now (it can open on iPhone, for some reason.)

Though, since you mentioned you're running Catalina, so if you're fine with it, you can download the installer by using terminal command:

softwareupdate --fetch-full-installer --full-installer-version 10.14.6

This downloads Mojave's installer at /Applications. I suspect it won't let you downgrade Catalina to Mojave though.

4
  • This gives the errors: softwareupdate: unrecognized option --fetch-full-installer softwareupdate: unrecognized option --full-installer-version
    – jan
    Dec 10, 2021 at 6:20
  • @jan Hm? I thought you were currently running on Catalina? Those options were added when Catalina came out. Are you sure you're running on Catalina?
    – Skye-AT
    Dec 10, 2021 at 6:47
  • Ah, sorry, that's why, I am running Mojave, so that must explain it (I'm not the OP, btw, :) ... just someone who came across this just now as the links from the Apple website seem to be broken.) Are you aware of any equivalent command to the one you list that would work on Mojave?
    – jan
    Dec 11, 2021 at 4:35
  • @jan Oh! I didn't notice that you weren't OP, lol. Sadly, there's no command like that in stock MacOS, though there's a tool called gibMacOS(turorial) that does (almost) exact same thing. Though, I've not used this tool(since I've never tried to download older macOS while running on below Catalina), so I'm not sure it'll work on Mojave.
    – Skye-AT
    Dec 11, 2021 at 11:31
0

You have truncated the URL, as given in:

https://support.apple.com/en-us/HT211683

The correct link is:

https://apps.apple.com/us/app/macos-mojave/id1398502828?mt=12

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .