0

When using Safari 14.0.3 on Mojave, if I paste https://gramhum.com in the address bar, I am redirected to greatfon.com, but the "https://" part disappears and the query is sent unencrypted via port 80. It is blocked by the firewall, so it fails.

I have to manually retype the URL to make it work. Same thing happens if I click the link inside an HTML file.

The option "Show full website address" is enabled, and if I replace https://gramhum.com with https://greatfon.com, it works.

I have no problem with Firefox and Chrome (these browsers redirect properly to https://greatfon.com).

11
  • 1
    Is there not a padlock icon before the URL? Do you have a Proxy?
    – benwiggy
    Apr 18 at 21:33
  • What version of Safari? Safari 14.0.3 tells me that anywebsite.com's certificate expired Monday, 24 August 2020 at 09:59:59 Australian Eastern Standard Time
    – Gilby
    Apr 18 at 22:34
  • 1
    I think the web address in the post is a 'fake' address, like somebody@gmail.com or 'yoyodyne.com`.
    – IconDaemon
    Apr 19 at 0:13
  • 1
    @IconDaemon I did wonder if that were the case. Then I would like some real examples.
    – Gilby
    Apr 19 at 4:32
  • 1
    For me Safari 14.0.3 on macOS 11.2.3 both https://gramhum.com and http://gramhum.com redirect to https://greatfon.com which I gather is what you expect.
    – Gilby
    Apr 19 at 7:02
2

I wonder if you may be seeing a feature that was a bit controversial when Apple introduced it, namely, not showing the full website address.

If you go to Safari > Preferences > Advanced and check "Show full website address." and then once you are on "https://anywebsite.com" just click once in the address field. That should show everything including the http/https string.

Does that solve your issue? If not please edit your question and add some more details so we can assist.

1
  • "Show full website address" is enabled. Apr 19 at 6:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .