I am working on iMac Retina 4K 2017 with macOS Big Sur v.11.2.1.

The Ethernet is connected to the iMac but unfortunately no internet access.

I've tried these approaches:

  1. I've created new location and add Ethernet with Configure IPv4 is Using DHCP.
  2. I've tried Renew DHCP Lease.
  3. I've tried to Configure IPv4 Manually and add Google DNS Server as my DNS Server.
  4. I've re-plugged in the ethernet cable.
  5. I've restart the iMac either before or after above configuration.
  6. I've unchecked all Proxies.
  7. Router has been restarted.
  8. Etc. (i don't remember the others).

All the above approaches doesn't work at all.

enter image description here

I plugged in my cable on Windows PC and it worked beautifully! But unfortunately doesn't works in this iMac.

How to solve this ?

  • Have you previously been able to use ethernet on this Mac? If so, when did it stop working? That is, did it stop working at the same time something else changed (e.g. upgrade to macOS Big Sur, change in router, etc)? Also, when you say, "I plugged in my cable on Windows PC and it worked beautifully!", can we assume it's the same ethernet cable plugged into the same port on the router?
    – Monomeeth
    Commented Apr 7, 2021 at 6:21
  • Also, if you disable Ethernet (click on the little circle at the bottom of the Interface list and select deactivate/disable) does it work as expected over WiFi?
    – nohillside
    Commented Apr 7, 2021 at 6:39
  • Other tests: if the WiFi is connected to the same network, does it have the same IP address prefix (i.e. 192.168.1.x), subnet, router, and DNS servers? Does it work if you leave the Ethernet connected & on, but turn off WiFi? Also, does the Windows PC get the same address prefix, subnet, etc when it's connected & working? Commented Apr 7, 2021 at 6:51
  • @Monomeeth, yes i have, actually i am working on iMac that had been used by another person before me in my office, and then i asked him "was the ethernet working when you were working on this iMac ?" he said "yes, but needed more effort that i don't remember anymore". I assume it stopped working when first time i used it and the OS was Catalina. And then i did above approaches until i decided to upgrade it to Big Sur and then did above approaches again. You can't, the current cable and previous cable isn't plugged into the same port. But i've connected to previous port but still not working. Commented Apr 7, 2021 at 8:00
  • @nohillside Yes the wifi is working beautifully. Even i am online now over WiFi. Commented Apr 7, 2021 at 8:03

1 Answer 1


The Ethernet service is shown as Connected, so the physical ethernet link was successfully established.

An IP address was received by the DHCP server, as well as a valid configuration for subnet, gateway and DNS servers, so communication from your Mac to the DHCP server (in this case your router) was successful. This rules out any problem with the ethernet connection itself.

You have already verified that changing the IP address does not have any effect, so we can also rule out firewall rules that block on that basis.

You have also disabled any proxy settings in the service's "Advanced" settings.

Therefore either A) it's a configuration issue on your Mac or B) your router blocks connections from/to the MAC address of your Mac's ethernet adapter.

  1. To rule out any possible service misconfiguration, remove the Ethernet service (with the button - below the list of services) and add it again. Don't forget to click Apply when done.

  2. Make sure you have disabled all apps that reconfigure your routing (e.g. VPN) or filter your traffic (e.g. firewalls).

  3. Try doing a traceroute. This helps determine where packets stop. Open Terminal.app and run the following command to trace a route to your ISP's DNS server (which I've taken from the screenshot):


If this doesn't provide answers, take a look at the router configuration and logs.

  • 1. Actually i had tried the point 1 but still not working. Today i tried it again and by deleted and added Ethernet again, but still not working. 2. As we can see in the screenshot i don't have any VPN on this iMac and also i have turned firewalls off but still not working. 3. I have tried to traceroute like your mentioned above, these are the given outputs: 1 proxy.vegatech.local ( 0.869 ms 0.560 ms 1.040 ms 2 * * * 3 * * * 4 * * * ..... By the way i don't know what the stars mean. Commented Apr 9, 2021 at 2:34
  • @Chrollolucifer The stars mean that no response was received from these hosts. The result of your traceroute indicates that the connection from your iMac to proxy.vegatech.local works, but that this proxy will not forward your connections to the internet. From my point of view, it's a problem with the proxy and not the iMac. Commented Apr 9, 2021 at 10:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .