At home I have a Dynalink RTA1025W DSL modem.

  • MBP can obtain IP via WiFI
  • MBP cannot see modem or get IP via ethernet.
  • Ubuntu/Win7/Win8 can get IP via the same ethernet cable & modem.

At work:

  • MBP can see the LAN and obtain IP via ethernet using the same USB ethernet adapter.

When I'm at home and I attempt to get an IP address via ethernet, I open the network preferences | USB Ethernet | Advanced | Renew DHCP Lease. It thinks about it for a second, then puts focus in the box titled "DHCP Client ID", as if it expects me to type something.

The status remains "cable unplugged". Either the cable for USB Ethernet is not plugged in or the device at the other end is not responding.

If I try to ping my router's address (192.168.1.1) no route is found.

I have tried many different cables, all otherwise known to be working.

Occasionally, the network config will decided to allocate a self-assigned IP, which is not helpful. It does this at random times without any prompting from me.

When I touch the USB ethernet adapter dongle it is warm (this may be normal).

I have tried the following without success:

  • deleting and re-adding the USB Ethernet interface
  • creating a new network "location"
  • removing the file com.apple.plf.plist
  • assigning manually an IP from the valid range
  • safe boot (problem occurs in safe boot)
  • SMC reset & wait 10 mins
  • PRAM reset
  • removing NetworkInterfaces.plist and preferences.plist
  • removing SystemConfiguration/*
  • trying a different cable
  • trying a different ethernet port on same modem
  • trying a different USB port on MBP

Any other advice?

Do you get the same result when starting up in safe boot?

This could either be an Ethernet driver or a hardware issue. One of the first things to try is perform an SMC reset (shift-ctrl-alt-power). I usually go a stage further and disconnect the battery for 10 minutes, this can clear SMC-related issues that the official method doesn't always cure such as errant SD card readers disappearing etc.).

After an SMC reset perform a PRAM reset (alt-option-p-r).

Your problem should be cleared by this stage but if not you need to look at your preference files in /Library/Preferences/SystemConfiguration, particularly NetworkInterfaces.plist and preferences.plist. Move them to your desktop, reboot and see if connectivity is restored.

Another way to check if it's a software issue is to create a clean install of OS X on an external drive. If your Ethernet port is working under the new OS then you will know it's definitely an OS problem rather than hardware.

  • Thank you Scunner. I have tried (almost) all your suggestions without luck. Question updated. – Synesso Dec 12 '14 at 22:52
  • ... I didn't remove the battery as I assume that means unscrewing things. I'm not going there. – Synesso Dec 12 '14 at 22:59
  • You don't need to remove the battery, just unplug it from the logic board for a few minutes. The card reader on my 2011 15" MBP occasionally disappears from the system. Disconnecting the battery is the one and only thing that restores it's functionality on my Mac and it's a cheaper fix than unnecessarily replacing the logic board. This has only happened twice in three years so it's not a major issue, but I like things to work properly and there are only ten easily accessible screws to come out. A standard SMC reset doesn't touch it. Answer updated, see above... – ScunnerDarkly Dec 13 '14 at 11:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.