7

Seeking some resolution with a Homepod Mini. Recently replaced our 11+ year old router with a Linksys WRT3200 ACM dual-band model, running OpenWRT. After initial setup everything on the network connected immediately, including the Homepod. Unfortunately this didn't last long. Homepod is now showing as unavailable in AirPlay from any iOS device. It shows in the Home app and if touched there will display comnnectivity, settings, etc. but lists "controls are unavailable". The device is clearly on network - it shows as connected from the router interface, responds immediately to ping, and appears as an available AirPlay option from my MacBook - if and only if I am connected to ethernet. Over wifi, it is unavailable.

What's especially maddening is that the two Ikea-branded SONOS speakers we had prior to the Homepod show in AirPlay all the time and work immediately from all our devices. I can stream to our Roku devices via AirPlay as well. I simply can't use the Apple-branded speaker. I can't figure out what the issue might be.

I've tried completely resetting the Homepod. I received a warning on setup that peer-to-peer communication was not available. I'm unclear why, as there's no setting in the router wifi config that makes me think mDNS is unavailable, and I have ensured the mDNSresponder package is installed on the router. The ONLY thing I can think might be an issue is that the Homepod is connected to the 5ghz radio (radio0) whereas the other AirPlay devices are on the 2.5ghz radio (radio1). Signal to noise ratio is consistently solid, it does not appear to be related to weak signal or interference. I've read that AirPlay can have issues crossing between radios in a dual-band setup, but my iPhone is on radio0 and plays through the SONOS speakers on radio1 just fine - and can communicate but can't PLAY to the Homepod also on radio0. If it's a cross-band issue I'd think the reverse would be true.

I don't know if it is an OpenWRT issue or an Apple issue. I'm new to OpenWRT (was running TomatoUSB for years). It's frustrating that this single device seems to be the only one giving me any real trouble. Any suggestions would be appreciated.

12

...and just like that I found a solution. IGMP snooping wasn't enabled in the LAN bridge, so AirPlay packets were not being routed correctly between wired/wireless devices. I didn't even consider that the LAN settings would be part of the problem, as all devices involved were wireless. Unclear to me whether the mDNSresponder package is required for the router to make this work, but it's working now.

5
  • 2
    You can accept your own answer to your own question. That way it becomes a good answer for future users. Also it is encouraged to do so if I remember correctly :-) – Steve Chambers Mar 21 at 16:16
  • Yeah, VLAN tagging can make things really tricky - even on commercial devices like store.ui.com It’s easy to mess things up with a setting that doesn’t seem to be relevant. – bmike Mar 21 at 16:17
  • 2
    There is a delay enforced for self accepts @SteveChambers - don’t forget to vote up good Q&A while the OP has to deal with the system delays... – bmike Mar 21 at 16:18
  • It's not a full solution. I'm still not seeing handoff working correctly if I hold a device near the HomePod, but at least we can use it as an AirPlay device again. Will accept answer once the delay in doing so is past! – dr.nixon Mar 22 at 20:27
  • Finally seem to have it all functional. Missing step was forcing the HomePod to connect only to the 2.4ghz radio. I blocked the MAC address on the 5ghz band for this purpose. It’s consistently working as expected now, including handoff. – dr.nixon Mar 28 at 14:07
0

my hero, just bought a 2nd HomePod since they're being discontinued and I figured I should get one for stereo audio pair while they're still available. Couldn't get stereo pairing to work at all, I got the HomePods to tell me "peer to peer" wasn't available on my network and couldn't for the life of me figure out what I needed to change on my Ubiquiti network. This did the trick, stereo pair works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .