1

I am trying to use AirPlay mirroring in a conference room-style setup using a 3rd-generation Apple TV. All software is fully-updated (as of 7/24/2014).

All devices are connected to a strong network without any password.

From an iPhone 4s, the AirPlay service shows up in control center, and mirroring works fine. From an Early 2014 MacBook Air, AirPlay never becomes available in the menu bar or in Display preferences, OR in regular iTunes.

What should I do to try to troubleshoot this?

EDIT:

I had been wondering if there was a subnet issue of some kind, but it appears not. For illustrative purposes, the Apple TV is 10.10.17.217. Two iOS devices can AirPlay to it from .18.8 and .18.196, but the MacBook Air cannot from .20.127. All have the same subnet mask of 255.255.240.0, and are pointed at the same router (.16.1).

I suppose I still need to try with other AirPlay endpoints and with other MacBooks, but I've really got nothing to go on beyond guess and check.

Aaaand I just checked with an iMac connected to the same network, .17.118. Nothing.

...

OKAY HOLD ON A SECOND.

I did a teeny bit of Googling and found some references to Bluetooth being added as a substitute/supplement for Bonjour discovery of AirPlay in a recent update. On the hunch that iOS devices are a bit more promiscuous with Bluetooth than the Macs would be, I tried testing the iOS devices with Bluetooth turned off. Here's the thing: once you're connected, you can turn off Bluetooth, but if Bluetooth is not turned on, you will not be able to see the AirPlay endpoint.

I noticed there was a Bluetooth setting in the Apple TV as well, and saw that it was just on and searching. Upon turning it off, the AirPlay option immediately disappeared from the iOS devices. Back on, and the option reappeared. Still nothing from the Macs.

The Apple TV is running software version 6.2 (6698.99.50.31).

What the hell is going on here?

2

First thing I'd check is whether the firewall is enabled on your Macbook and blocking incoming packets. If the firewall is on, try turning it off temporarily for a few minutes to see if the AirPlay icon appears in the menubar.

Next thing to check is whether the devices are on the same subnet. You can find the IP address and subnet mask of your Apple TV in Settings -> General -> Network. And the IP address and subnet mask of your Macbook in System Preferences -> Network -> Wi-Fi -> Advanced... -> TCP/IP. Ideally what you should expect to see is the same subnet mask on both devices (likely something like 255.255.255.0) and IP addresses that are similar except for the number after the last dot (something like 192.168.0.125 and 192.168.0.138).

Those are the two things I'd check first. Check those and let us know how you get on.

Apple have a guide to trouble-shooting AirPlay problems for Macs. There are a few other things that might help too: About AirPlay Mirroring in OS X

  • You know, I had a hunch it had to do with sub-netting... This is just barely out of my area, but here's what I remember (I'll check to be sure later) -- the subnet mask is 255.255.240.0. That means 20 bits of network and 12 bits of host, yes? So the third octet of the host IPs must ALL be within a 0-15 range (or 16-31, 32-47, etc.) and if I have one host with .15.xxx and another with .16.xxx, they are not on the same subnet? – NReilingh Jul 25 '14 at 14:01
  • Hrm, my hunch was wrong. Editing question. – NReilingh Jul 29 '14 at 0:00
  • The firewall was indeed the problem as far as I am concerned. Thanks! – DomQ Mar 17 '15 at 20:37
2
+50

What's happening is that since Apple TV OS 6.1 and iOS 7.1, iPhones and iPads have supported Bluetooth discovery of Airplay services for Apple TVs.

What this means is that even without doing any pairing, the Bluetooth does a "handshake" between the iPhone/iPad and the Apple TV that exchanges discovery information. This means that even if you're not on the same network, you can "see" the Apple TV. Note that the Airplay itself doesn't take place over Bluetooth... that still happens over Wi-Fi/Ethernet. The Bluetooth "handshake" just tells the client device the IP address of the Wi-Fi or Ethernet interface of the Apple TV that the client can find the service on.

This is immensely useful in enterprise type environments where these things tend to be on different VLANs, because the Bonjour protocol that normally serves this purpose is a broadcast protocol that doesn't cross network boundaries without help from a Bonjour relay service like Avahi.

Unfortunately, this Bluetooth Discovery feature has not been available for Macs, which is why your iPhone/iPad can see the Apple TV and your Mac cannot. Fortunately, with the latest beta release of Apple's Yosemite OS, this appears to be working now (Hooray!)

It also appears that Apple is implementing a peer-to-peer Airplay system in iOS 8 that doesn't rely on corporate networks at all.

Hope this was clear and helpful, Drax

  • So are you suggesting that the Bonjour discovery method is broken currently? – NReilingh Aug 4 '14 at 6:49
1

I had a very similar issue, the subnet masks matched, and both my apple tv (gen 1) and my macbook pro (non-retina) were connected to the same network, same subnet, etc... But, I could not airplay from my mac to my apple tv. I could sync the apple tv, sharing or not sharing photos....

I reset the network on the apple tv (chose the same network, reentered the password) and then almost immediately, I could airplay from iTunes on my computer to my apple tv.

0

Is air play mirroring enabled in System Preferences? To enable it open System Preferences and click on the displays. Then at the bottom there should be a check next to show mirroring options in the menu bar when available. If not click the box to enable it. enter image description here

  • Yes, of course. On a laptop, there's even an AirPlay Display setting right above that that indicates "No Devices Detected". – NReilingh Aug 4 '14 at 6:25
0

I had a similar issue and the reason for not being able was the firewall.

What I found out are the following cases:

(1) Firewall deactivated -> Airplay should work.

(2) Firewall activated, Block incoming connections: OFF -> Airplay should work.

(3) Firewall activated, Block incoming connections: ON -> Airplay does not work.

In my case after moving from (3) -> (2) everything was fine again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .