When saving a Microsoft Word document directly to a SMB share which was mounted using a bookmark and authenticated with an Open Directory "Network User Account", the saved document becomes invisible.

This seems to be caused by the quarantine flag, which all network shares have when mounted with a bookmark (or AppleScript, for that matter). The flag can be seen by using the mount command in Terminal.app:

% mount
//[email protected]/test on /Volumes/test (smbfs, nodev, nosuid, quarantine, mounted by someUser)


  1. Is there a way to create a SMB bookmark that doesn't result in the mounted volume having the quarantine flag?
  2. Is there a way to prevent Word.app (or whatever process is responsible) from making the file invisible?

Affected Environment:

  • macOS Server versions: macOS 11, 10.15, 10.14, 10.13, 10.12 and possibly others
  • macOS Client versions: macOS 11, 10.15 and possibly others
  • Word versions: 16.48, 16.46, 16.45 and possibly others
  • Local user account type: irrelevant; happens to admins, regular users and guests
  • User account type to connect to SMB share: "Network User Account" via Apple Open Directory and possibly other directory accounts

Steps to reproduce:

  1. Open Finder
  2. Press Cmd-K to connect to a server
  3. Enter server address "smb://someServer" (where someServer can be a domain or an IP address)
  4. Select the entered server address and drag it to the desktop, thereby creating a bookmark to the specified SMB server
  5. Double-click bookmark the open it. The typical dialog prompting for user credentials should appear.
  6. Enter your user credentials (of a network user account from Open Directory)
  7. Mount any share
  8. Open Word.app
  9. Create a new document and enter some text
  10. Save the document on the mounted share

Result: The saved document might appear for an instant, but will then vanish. It can be made visible again using chflags nohidden, so it actually is saved but just made invisible by some unknown process.

  • When you connect to a saved server through the Connect to Server dialog, instead of the bookmark, are the files visible?
    – IconDaemon
    Commented Mar 10, 2021 at 2:46
  • 1
    @IconDaemon Yes, when using Cmd-K or the Finder's sidebar to connect to the server, the mounted share doesn't have the quarantine flag and documents saved from Word show up as expected. Commented Mar 10, 2021 at 13:49
  • I've read (on a reddit post, so a grain of salt is required) that the quarantine flag started happening on Big Sur. Unfortunately, I no longer have any SMB servers to test this even further. I would suggest that the Command-K > Click Server method supplant the alias (shortcut) method for now. It's only a keystroke and a click vs. a click.
    – IconDaemon
    Commented Mar 10, 2021 at 15:22
  • 1
    @IconDaemon macOS Catalina definitely was affected, too. Unfortunately, some of my users are first graders, so the workflow needs to be as simple as possible. Manually entering the connection string (each time, as we're using Guest accounts) isn't really feasible. I know, really specific requirements – sorry about that. :) Commented Mar 10, 2021 at 17:20
  • Seems Apple’s commendable enthusiasm for security isn’t matched by an enthusiasm for thinking about consequences. I’ve had a lot of permission denied trying to look at filenames (ls) in my own ~/Library
    – WGroleau
    Commented Mar 13, 2021 at 18:21

1 Answer 1


I found same problem. If I do open 'smb://user@server/myshare' the mounts end up having smbfs, nodev, nosuid, quarantine. However if I use CMD+K to mount, the mount has only smbfs, nodev, nosuid, no quarantine attribute.

Am still looking for how to get the same cmd+k mounting done using the shell script.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .