1

I have set up a samba share on my local network using a raspberry pi. I can mount the share from my Linux machine and ios devices (using Fileshare), but can't from my new macbook pro running el capitan. I use cmd+k in finder and type in the user credentials, but get an error message (in danish) saying something along the lines of 'there was a problem connecting to the server'. I have tried changing smb:// to cifs://. I get the dialogbox with the user credentials, but it now shakes, as if my password is wrong. It even gets more weird - I am able to use ssh from the terminal with no problems...

Does anyone know what's going on? And what to do?

0

If you are familiar with connecting via Linux via /etc/fstab, then you know there are a lot of possibilities of what could go wrong simply because there are SO many different options for connecting to different types of network shares, and it seems like every OS handles these options differently.

I have encountered issues similar to this before, and in my cases, it was always either an issue with ownership/permissions and/or the specific mount point (or a combination of the two):

For instance, I have a ZFS pool setup using FreeNAS, and the mount point is set to //x.x.x.x/share, and the login credentials are supposed to be for a specific user. I have no trouble connecting to it in Windows, but the only way I can connect to it in OS X is to connect directly to the IP using the root credentials. I know there is a way to fix it, but I haven't gotten around to looking into it yet.

So my first advice would be to try connecting directly to smb://x.x.x.x or smb://x.x.x.x/share, or any other variations that you can think of, using various sets of credentials that have access to that box.

It could also be a Samba version issue (which Samba is notorious for) that could be causing these 2 guys to not agree with each other.

Also, sometimes in OS X if I am trying to mount a share with one of the various mount commands in Terminal, I find that it tends to give me trouble sometimes if mounting with my normal user, so in certain circumstances, I need to use sudo in order to mount it as root.

If all else fails, I would try installing the Netatalk packages on your Raspberry Pi. Netatalk is an open source version of the Apple Filesharing Protocol (AFP), which OS X obviously tends to handle much better than Samba (SMB). If you enable the share to also use AFP, you can connect to it from Finder using afp://x.x.x.x/share, etc.

If you are running Raspbian, those packages should be available via apt-get. I hope this helps!

  • Hi Rubynorails. Thanks for your quick answer! I have tried connecting directly and using smb and cifs and tried to connect as root to no avail. I am on samba version 4.1.17-Debian - do you know of any version conflicts with that and OSX 10.11? If I understand you correctly, it is possible for the same share to make both the smb and afp available - is that right? And if it is - how is that done? Through the smb.conf? – BBKim Dec 13 '15 at 22:03
  • No, it would not be done through smb.conf. You would have to setup AFP separately, but pointing to the same directory/mount point. It has been quite a while since I have done that manually, as FreeNAS does it automatically, so I don't feel qualified enough to speak on how to go about setting that up, but it should be readily-available somewhere if you Google something like "Debian Netatalk AFP setup configuration" (without quotes, of course). – rubynorails Dec 14 '15 at 1:16
  • It worked!!! I installed netatalk simply using apt-get install netatalk. I then used this easy instruction to set it up with my hdd: raspberrypi.org/forums/viewtopic.php?f=36&t=26826. Thank you so much for your help!! – BBKim Dec 14 '15 at 8:01
  • Great news! Now give my answer an upvote and click the checkmark to accept it as the solution! Very glad to hear this was able to help. – rubynorails Dec 14 '15 at 16:55
  • Absolutely - have I done it right? – BBKim Dec 14 '15 at 22:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .