1

I long for the days of 3.5mm connections and headphones that connect directly to the audio source.

Very often (~20%) on a Skype call, my AirPods fail to connect to the correct device. Which leaves me on a conference call that everyone around me can hear.

Here is specifically what happens:

  1. Skype rings (iPhone & Mac)
  2. I answer the call on Mac
  3. I hear that connecting sound on the AirPods
  4. The Mac shows "connected AirPods"
  5. I hear another connecting sound on the AirPods
  6. The Mac shows "moved to nearby device"
  7. The iPhone stops ringing
  8. I select bluetooth/AirPods and/or sound menu/AirPods
  9. I hear another connecting sound on the AirPods
  10. The Mac shows "connected to AirPods"
  11. The audio from the Skype call is playing through the Mac speakers
  12. I open Skype preferences/audio and select AirPods
  13. 50/50 the AirPods will play the audio, or I need to restart Skype and start over

Instead this is what I want:

  1. Skype rings (iPhone & Mac)
  2. I answer the call on Mac
  3. I can start talking

Possibly related and more general questions that did not answer this:

2

Go to System Preferences → Bluetooth and for your AirPods choose Options and set ‘Connect to This Mac’ to ‘When Last Connected to This Mac’.

When Last Connected to This Mac

Now your AirPods won't automatically switch away from your iPhone to your Mac. Make the equivalent change on your iPhone to stop the other way round.

Then your AirPods will always connect to the last device and you can manually select your AirPods from the Bluetooth or Sound menu to connect them to your desired device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .