1

This question is not duplicate as this thread didnot solve my problem since I cannot upload my data on Icloud. I am trying to restore data from a folder which I later found is similar to .pages package contents. It has subfolders Index, MetaData, file.zip and some jpeg images as preview. I also came across several other threads 1 2 which all suggests to change the folder extension to .pages or copy contents first and then change etc etc. I have done all that, but Pages [10.3.5] still wont let me open this file. Data in folder is also some encrypted format .iwa. I also searched to understand this format to extract data but it is some kind of compression (Snappy) which I guess can only be read by application (please correct me otherwise).

So far I have tried changing extensions and copying contents into a new folder and then change extension. I cannot upload data on Icloud. Is there any other way around to get data back? Is there any editor for .iwa files to read data?

Thanks.

1

The folder was originally a file created in Numbers not Pages.

Since I was given data as a folder with some .iwa files. When I read on internet about opening those files, all posts were regarding Pages rather Numbers. As package contents were same for both formats (.pages and .numbers) I kept trying opening the folder (by extending .pages) in Pages.

Later on I tried Numbers (giving extension .numbers to folder) and it worked instantly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .