1

I made a big mistake and updated some Python packages with Homebrew on my 2015 MacBook Pro, MacOS 11.0.1. The updates caused many issues with my preferred IDE, PyCharm. Of course, I made a backup on my Time Capsule prior to updating with Homebrew. So, after being frustrated and getting nowhere with PyCharm, I decided to restore from my backup. I entered into recovery mode by holding CMD + R while restarting. When I went to restore from backup, I could not connect to my Time Capsule. The prompt stated, “There was a problem connecting to the server.” Any ideas on how to get the MacBook to connect to the Time Capsule?

3 Answers 3

2

After over an hour on the phone with Apple, it was suggested I try to use Migration Assistant to restore from backup. That worked for me.

EDIT: While it did work, there was a major issue: While trying to run Python/Jupyter in PyCharm, I repeatedly get malware warnings that have to be manually suppressed, individually. I mean, every file associated with a Python package in the virtual environment seems to be identified as possible malware. I called Apple about the issue, but no one knew how to globally suppress the malware warnings. There are way too many files to manually suppress them all.

I found an alternative, create a new project in PyCharm, copy in Python/Jupyer files (not packages, but files I created), then add the packages needed to run everything.

1

I unfortunately have no real solution but as I recently also installed Big Sur on a MacBook Pro Late 2013 and wanted to revert back to Catalina. I got the exact same error message “There was a problem connecting to the server.” when trying to connect to the Time Capsule through recovery (CMD+R mode) - (also shown by me as NAOpensession failed for afp:// ... - Error 22) in the log window when seeing extra details.

I later made a copy of the sparsebundle (from the Time Capsule) to an external hdd and could make it further through the recovery screens. (I didn't finalize the steps as I later read Big Sur may brick 2013 MacBook and didn't want to take any more risks - but it looks like I could have made the complete recovery through the hdd with the same backup copied from the TM). This may be a potential temporary alternative

I also did further testing my on wife's laptop (still on Catalina) and she received the same error (There was a problem connecting to the server...). I suspect the bug may not be new to Big Sur.

I also made a hard factory reset of the Time Capsule and made two new backups that are working and are verified perfectly on Big Sur itself, but once in recovery mode it fails to connect to it.

Regards

1
  • After talking to an senior Apple representative, I realized they have no idea either. The representative told me that I have to delete my SSD before I could connect to the Time Capsule. Literally never had to do that before. I said, "so you are suggesting that I erase all of my files, even though I cannot connect to my Time Capsule? Seems like the worst way to proceed!" I ended that call and went back to Catalina. Nov 27, 2020 at 23:53
0

„NAOpensession failed for afp:// ... - Error 22“ is also the case for Big Sur 11.1.

I needed to go down to the shipped os for this machine (10.10) and then back to catalina again to gain access to the backup. From catalina I could sucessfully recover the Timecapsule Backup. My recommendation is to have a big usb3 thumbdrive at hand and format it as startup drive, that can spare a bit of this trouble. https://support.apple.com/de-de/HT201372

Sadly one can not choose which specific version of Mac OS the internet recovery loads, only the one from hardware production time and the last installed, which is Big Sur when you have the problem.

The Problem itself is unrelated to Python or Homebrew, i needed a backup after the Mac Server app forgot it´s settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .