0

Recently Time Machine has stopped backing up to my Time Capsule on both my MacBook Air and MacBook Pro. It spends a few hours "Preparing backup" and then just gives up.

I've had a look in Console and when it says it is "Preparing backup" com.apple.backupd is running an initial consistency scan for '/' and then when it stops I get the following messages in the Console:

Error writing event cache at /Volumes/Time Machine Backups/Backups.backupdb/... : Error Domain=NSPOSIXErrorDomain Code=20 "Not a directory"
Error writing to backup log. NSFileHandleOperationException:***

The latest backup on my MBA is 23 July and on my MBP is 24 July so I think that coincides with me updating OS X but I can't be sure. These are the things I have tried so far (I've turned Time Machine off on my MBP so I can focus on getting the Air working first)

  • Turning time machine off and back on again
  • Reselecting the back up disk
  • Hard resetting the time capsule
  • Factory resetting the time capsule
  • Booting into Safe Mode on my MBA and then restarting into normal mode
  • "First aid" (Disk Utility) on my MBA
  • Renaming the Time Capsule to a short name

The only thing I haven't done is erase the contents of the Time Capsule for two reasons. 1) I don't have a hard drive with enough capacity remaining to archive the data to. 2) When I enter Time Machine all of the backups are there and available for me to restore so I don't want to loose all that.

Please let me know if you have any ideas. The TC has over 300 GB of space remaining.

UPDATE Here is the contents of the .sparsebundle (located within the 'Data' folder) that is the backup (the bands folder is empty): contents of sparsebundle created by Time Machine

  • If you turn off Time Machine, mount the Time Capsule in Finder, browse to the Backups.backupdb folder, open the disc image that corresponds to your computer, do you have a folder called inprogress something? If you remove the inprogress folder it usually helps with TM not being able to complete a backup. Delete the folder and enable TM and try a "Backup now". Otherwise perhaps a screenshot of the folder structure on the mounted discimage would help. – Niklas Aug 22 '16 at 10:36
  • @Niklas I have just uploaded a screenshot of the contents of the .sparsebundle as I don't have a 'Backups.backupdb' folder which I believe is because I'm backing up over the network? Let me know if you need any more information... Thank you in advance. – Andy Aug 22 '16 at 18:31
1

Usually, I wouldn't post an answer like this (rather, just delete the question) as my solution to this issue is so untechnical; however, I feel that it might just save somebody a head of hair.

It turns out that the Ethernet capable connecting the Time Capsule to the network switch was damaged. I never checked it initially because the Time Capsule was appearing on the network and my MacBook Air would back up to it fine, but all I can assume is that my MacBook Pro but more stress on the cable. Long story short, I've put a brand new Ethernet cable in and it worked first time, flawlessly.

Now, before I did so I had followed this tutorial to keep using the same machine after a change to the computer, so I don't know if that did have any effect or not.

I suppose the moral of the story here is that networking is a pain and you shouldn't overlook anything, even if it seems to be working perfectly!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .