2

After upgrading to macOS Big Sur (11.0.1), the notification of new messages only shows contact number instead of contact names. I can see contact name, profile pics in my Messages.app and Contacts.app, just not in the Notification Center.

I have enabled messages in iCloud on both macOS and iOS.

Any suggestions?

  • Did you manage to solve this? I am having exactly the same issue. – Andrew Ho-Lee Nov 27 '20 at 22:08
0

I managed to fix this by going to System Preferences > Language & Region. I changed the default language from English (UK) to English (Canada) and quit System Preferences. I then changed the default back to English (UK) and then quit System Preferences again. I then restarted macOS.

I have absolutely no idea why that works. From the number of similar posts on the internet proposing different solutions, I suspect there are multiple possible issues leading to the same problem. However, this it worked for me on macOS Big Sur 11.0.1. Unfortunately I can't find the link describing this solution to give credit but if anyone does find it do link in.

Hope this helps you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .