0

My question is the opposite of Contact names are gone, but still shown in Messages. I don't think I did anything to cause this, but yesterday out of the blue, some of my messages did not display the name of the contact, only the phone number. The same holds for phone calls. Yet the contacts are just as normal in Contacts. For the most part, it seems that older contacts are less likely to have their name and to only have their number. Some contacts have a new text chain opened for some reason. I sometimes get a message sent to myself as it thinks I am two people. I have contacts both in iCloud and Gmail.

Aided by suggestions from website, I have tried a ton of things, like:

  1. Turning the phone off and on
  2. Restarting the phone
  3. Toggling short names off and on
  4. Toggling iCloud-Contacts off and on (and using the delete from iPhone option)
    1. Import SiM contacts from both Gmail and iCloud

What else should I do?

  • I have found that if I add a +1 country code, then it shows up! But I don't want to do this manually. I have hundreds of contacts. – bill999 Nov 18 '18 at 5:51
1

The answer is from Some text messages showing phone number not contact name My language was set to English. I selected English again and it fixed it!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .