3

I've used "Forward Text Messages" for years to send SMS from macOS. Since last week, names of "SMS people" are marked RED in Messages, and I can't send SMS from macOS anymore.

I've updated to the latest iOS and macOS, logged out and in of iCloud on both devices, and flicked "Forward Text Messages" in Settings off and on several times, to no avail.

My only lead is that when flicking the setting, I'm supposed to be asked to enter a code (on the Mac, I think), but this does not happen. Apple Store had no idea and I've found no help on the Web.

Clicking on the red name shows this context menu:

✔︎ (number)                        iMessage  (Ghosted)
  (number) is not registered with iMessage  (Ghosted)
Remove (name) from chat
Show contact card

Also, the message field at the bottom shows "iMessage", where it said "Text message" before.

SMS sent from iOS are added to messages on macOS. So it works that way, but not from macOS to iOS (because Messages does not seem to know about SMS, only iMessage.)

NEW: Turned "Forward Text Messages" off, turned off both Mac and iPhone, turned both on, and turned "Forward Text Messages" on. I get no question about entering a code, and still RED names.

8
  • Try clicking one of the red headers & re-assigning the number. I've had that happen before, when something 'just got confused'
    – Tetsujin
    Apr 10, 2017 at 16:38
  • What do you mean by "re-assigning the number"? It has happened for all my "SMS contacts" (people without iPhones), so it's not linked to a specific contact.
    – forthrin
    Apr 10, 2017 at 17:13
  • so... what did you see when you clicked one of the headers?
    – Tetsujin
    Apr 10, 2017 at 17:21
  • See updated posting.
    – forthrin
    Apr 10, 2017 at 17:26
  • hmm... I'm sure I had perhaps a 3rd entry when it happened to me... either I had something I could select instead which made it re-think, or I opened the contact card [it's too long ago for me to recall exactly, sorry]
    – Tetsujin
    Apr 10, 2017 at 17:35

3 Answers 3

4

On your iPhone, do you have an email address checked under settings>Messages>"send & receive"?

for some reason, it only works when I have an email address checked which was not the case before. They must have changed something on their end to require the use of an email.

1
  • You're right. This resolved the issue. But why the @$!# have they changed this? Having multiple addresses for iMessage is guaranteed to create a mess (at least it did before!)
    – forthrin
    Apr 13, 2017 at 8:19
1

Thank you! This worked for me. Had to had email. Went back to just phone number and text only contacts turned red again and would've send messages. Could receive though. Re-added email and Contacts turned green again. They must have changed something on their end.

1

I had the same problem just now, and user233886 gave me the idea to try something on my iPhone. I went to Settings > Messages > Send & Receive, unchecked all my email addresses, waited a few seconds, then checked the email addresses again.

My Mac immediately asked if I wanted to allow something, and I accepted. After about 30 seconds, the names were no longer red in the Mac Messages app.

1
  • This worked for me. The additional messages were from your other devices that are sharing your iMessage texts, like my MacBook, my iPhone, and my iPad. Also, clarify, I did not uncheck the phone number in Settings>Messages>Send&Recv. Only the eMail addresses. Then waited a few seconds for the devices to all respond. In fact, in my case it cleaned itself up after some waiting without rechecking the eMails. I did that later, once the red names were back to normal in iMessage (on MacBook) Dec 31, 2021 at 20:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .