0

I am trying to use a tool written to help convert output of one program to a file useable by another.

The tool when downloaded is a lot of files and a .exe file.

I assumed this is not the Mac version, but the developer says that it runs on Mac OS and I need to CHMOD +x it and it will run.

I can't even get to the stage of trying that as my mac defaults to use the Unarchiver for .exe files. I have tried both SwiftDefaultApps and RCdefault apps to try and de-allocate the unarchiver to those files, but neither works.

I've changed the suffix manually to .app and tried to run that but am told "You can’t open the application because it is not supported on this type of Mac."

I have dug into the terminal and think I have chmod -x the file.

Is there something I should be doing, or is it just that an exe just never going to work on a mac?

I'm a bit confused.

Thanks for any pointers.

3
  • 4
    An .exe is never going to work on a Mac [without some sort of 'translator'], but it would be interesting to know what the app is & why the dev thinks it would; also what you are trying to convert to what. An .exe could be a self-extracting archive on Windows, rather than an actual app… but then we're back to knowing what it is & what it's meant to do. – Tetsujin Oct 30 '20 at 18:03
  • 1
    "The tool when downloaded is a lot of files" — maybe one of the other files is the Mac program – theonlygusti Oct 30 '20 at 18:19
  • Thanks for the suggestions @Tetsujin and theonlygusti I've looked through the files and there doesn;t seem to be a Mac one. I'll try and contact the dev. Just for completeness it is this tool to convert dialogue to ren'py, a visual novel maker. link The relevant info is: dxDD2RenPy is a cross platform application. It works on: Windows, Linux, Mac OS X. Just run "exe" in the archive on your operation system and You will need to set executable flag on Linux and Mac OS X (chmod +x dxDD2RenPy.exe). I'll see what he says. Thanks for your input. – AskingQuestions Oct 30 '20 at 18:47
4

I have downloaded the program and can confirm that the exe file is indeed an ordinary exe file - and definitely not a script file for Linux or anything of the sorts.

I would assume that when the author mentions that the project is cross-platform, and allows running on Linux and macOS - he means that you could install the Mono Project and run the program that way.

However executing the exe file via mono like this:

mono dxDD2RenPy.exe

doesn't actually work. It does work with other .NET cross-platform exe files though.

2
  • Thanks very much for doing that, it's very helpful and saved me a lot of messing around. – AskingQuestions Oct 31 '20 at 9:44
  • Looks like it was created using Avalonia but the macOS packaging steps weren't done? From their docs: avaloniaui.net/docs/packing/macOS. – lx07 Oct 31 '20 at 17:59
-2

The file is probably just a script file for Linux and may run fine using the command line. From the command line type chmod +x filename and the just type the filename or ./filename.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .