1

I have this pesky file "qmasterd" that has been moved to the "Incompatible Software" folder by the macOS Installer. It must have been lying around on my Mac from years ago when I had Final Cut Pro v6 installed. Anyway, I cannot delete it, and I've tried a lot...

The file has these permissions:

-r-sr-sr-x 1 root daemon 280688 27 Apr 2007 qmasterd

When I try to chmod, chgrp, or chown all I get is:

bash-3.2# chmod g-s qmasterd chmod: Unable to change file mode on qmasterd: Operation not permitted

Ideas please?

  • Odd... I just found the same thing & tested throwing out the individual components & also the overall 'Incompatible Software' folder simply from the Finder with Cmd/backspace. Gave it my admin pw & no issues. – Tetsujin Oct 30 '18 at 9:41
  • Thanks Tetsijin, are you saying it deleted fine? Have you emptied the Trash too? – Pete Oct 30 '18 at 10:05
  • Yes & Yes. I first tested several methods to delete, but essentially just various combinations of 'simply making the Finder throw it in the Trash'. Each time I undid the operation & tried again - folder, each file etc. Eventually I tested Empty Trash, & it's gone for good. I didn't see any error at all, only the requirement to give my admin p/w. Ahhh... late thought... I have SIP disabled. Maybe that's it. Test in Terminal with csrutil status though, of course, you can only toggle it from Recovery. – Tetsujin Oct 30 '18 at 10:08
1

Right, a solution that worked for me...

Restart in Recovery mode, launch Terminal from the Tools menu, move to the directory with the offending file, rm filename and "Bob's your Uncle!" :-)

1

The problem in this case is that the file gets protected by SIP at some point and then gets moved while retaining that protection. A SIP-protected file cannot be altered or deleted, not even as root (hence the alternate name ‘rootless’ for SIP).

Temporarily turning off SIP or deleting it while the main system is not running (i.e. from recovery mode as suggested or from Target Disk Mode) is the only option that remains.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .