1

I use a MacBook Pro as a Laptop and mainly Linux to work. Mostly i like to use the same Keyboard (Ducky one 2 SF) for both devices. I chose the same keyboard settings (German) in Mac OS as in all other Systems. My Problem is, that the top row on mac doesn't work as expected. It still works as if I use a Magic keyboard.

For example, I want to get [ with alt 8, but instead I get {.

One solution would be to remap all the different keys, which doesn't look as the best way for me. Is there any way to just use the natural keyboard layout of my selected keyboard?

4
  • Its mainly the alt/option layer, when i do alt+7 i get { on any os, on mac os i get |, when I do alt + 8 I get {, but I want the standard [, this goes for the full number row and most other keys liken >,< etc. I just can't imagin that remapping every single key by hand is the best way to go since it's just the standard layout. – CrownUpKid Oct 11 '20 at 2:20
  • Yeah standart german layout, but i also chose the german layout in mac os – CrownUpKid Oct 11 '20 at 2:48
  • 1
    In macos, try replacing “German”.by “German Standard” in theinput sources preferences. – Tom Gewecke Oct 11 '20 at 3:39
  • +1 for a good question...if I didn't personally go through this a couple of weeks ago, I wouldn't have known this was an issue. – Allan Oct 11 '20 at 7:05
0

Go to System Preferences > Keyboard > Input Sources and make sure the only item on the list is "German Standard" (and not "German").

The Apple "German" input source puts [ ] { } on alt 5689, while the German Standard input source should put them on alt 8970, and there are various other differences, such as @ being on alt L for "German" instead of on alt Q for "German Standard".

Because the differences are on the alt level, the printing on an Apple "German" keyboard can look the same as that on a "German Standard" keyboard, except perhaps for where @ appears as the 3rd item on a key. So it is easy to choose the wrong input source.

1
  • Exactly the answer I needed, thank you – CrownUpKid Oct 11 '20 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .