0

I've a strange Problem with my new Mac. During the Install i've used a Windows Keyboard, after the Install Process was completed i've switched my Keyboard to Apple Magic Keyboard.

But now i can't use the original Keymap for the Keyboard. At Example if i press alt+q it will draw an @ char. How can i change it back, so that the @ Char will be printed if alt+l is pressed?

The Keyboard Layout in Settings is set to German, i've also tried to change it from German to German (Default) back. But this take no effect.

Thanks for your help!

4
  • Anything else besides @ not in the right place? Feb 23 at 13:17
  • I don't see anything called "German (Default)" in Input Sources. If you try to add a German keyboard by using the + button, you should see German, German Standard, Austrian, ABC Qwertz, and Swiss German. What do you see? Feb 23 at 15:38
  • I'will test if there's another key whos on the wrong place. Sorry, i mean German Standard. I will Upload the Picture later, if i'll be back at the Mac.
    – 0xS74CK
    Feb 23 at 16:55
  • If you have ONLY ONE ITEM on the Input Sources list, and that item is called German, Austrian, or ABC Qwertz, you will have @ on Option L. If the only item is called German Standard, you will have @ on Option Q. If the only item is called Swiss German, you will have @ on Option G. Let us know what you get when those are the only items on the list. Feb 23 at 17:24

3 Answers 3

0

I would try adding "Austrian" in System Preferences > Keyboard > Input Sources and see if that works.

Then use that or try removing "German" and adding it again.

1
  • Thats solved the Problem. Thank you!!
    – 0xS74CK
    Mar 2 at 9:31
0

Go to System Preferences > Keyboard > Input Sources and add a new input source (using the plus button in the bottom left)

Choose an input source that matches what you want. Hold down the alt button to see what alt + the keys would produce.

0

Assuming you are using a German keyboard, go to system preferences > keyboard > input sources and make sure the only item there is called German (and NOT German Standard)

If you are not using German, tell us what language your keyboard is.

2
  • The Settings are correct. I'm using German as Input Source. But this do not solve my problem ....
    – 0xS74CK
    Feb 23 at 13:10
  • @0xS74CK Please edit your question to include a picture of your Input Sources preference pane, as it really should not be possible to get @ at option Q with "German" as the only item on the list. Only German Standard does this. Feb 23 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .