0

I have a 2010 white Macbook and the middle row of the keyboard has gone funny. The keys all work fine still but they no longer correspond to the correct key. Pressing a for example prints q, h prints y, ; prints p.

Caps lock, ', \ and Return all work fine on the middle row however.

I've tried reducing it to one stick of RAM, tried it in both slots to see if that was the problem. Still the same results.

With the keyboard viewer open I can see the same results being highlighted, as if the middle row isn't there.

I have bootcamp installed and the same results happen in Windows too.

I've tried hunting around for the same issue but I can only find broken keys, not mismapped keys. Does anyone know how I might go about attempting to fix this?

Also to my knowledge nothing was spilled on the laptop it just stopped working one day.

SMC reset hasn't fixed it and external keyboards working fine.

Thanks

  • 2
    Test with another USB keyboard to eliminate hardware. – Tetsujin Jan 30 '16 at 12:49
  • Ok, I'll try that. I've just tried resetting the SMC but that didn't help. – Steji Jan 30 '16 at 12:57
  • Sound very much like a hardware issue. – Max Ried Jan 30 '16 at 13:32
  • Logitech wireless keyboard working fine, could there be a loose cable I can fiddle with or further resetting of things hardware side of things? – Steji Jan 30 '16 at 13:56
1

The keyboard in your Mac may need to be replaced, but you could try just disconnecting and reconnecting the keyboard using a guide from iFixit for repairing polyurethane MacBooks. Select your model from the list and then select keyboard replacement. I've repaired a slightly older MacBook than a 2010 for one of customers before, and it wasn't all that difficult, but just take a look at the guide from beginning to end to make sure you're comfortable with the repair before you attempt it.

  • Thanks for this, I haven't had chance to get stuck into it but I'll let you know how it goes. – Steji Feb 24 '16 at 12:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .