When I was going to reinstall a fresh copy of macOS Catalina on my MacBook Pro (16-inch, 2019), unfortunately I deleted all partitions instead of erasing them. As my internet connection is so unstable as much as I repeated installing the OS from the net, it was failing with different errors usually related to the network errors or usually it says can't decode raw data.

I created a bootable media flash drive by these steps https://support.apple.com/en-au/HT201372.

Now when I want to boot the device from the USB drive, Choose startup disk

it says "Security settings do not allow this Mac to use an external startup disk". Security settings do not allow this Mac to use an external startup disk

I waned to allow my Mac booting from external media (as this link https://support.apple.com/en-au/HT208198) but It shows me the error: "Authentication Needed - You will need to authenticate as an Administrator to change the boot security settings."

ou will need to authenticate as an Administrator to change the boot security settings.

And when I click on Enter macOS Password I see this error : "Recovery is trying to change system settings. No administrator was found."

Recovery is trying to change system settings. No administrator was found.


  • I had never set a password for my mac T2 security
  • I had forgotten to sign out my apple id from the MacBook Pro but I've removed my device from my apple account after that.
  • The MacBook Pro doesn't have any operating system now, so I can't use solutions like rm /var/db/.AppleSetupDone

I've searched a lot and watched lots of youtube videos but didn't succeed anything yet. How can I fix my issue to allow me boot from the flash drive?

  • Sounds like you have a firmware password and you don’t remember choosing one? I’ll answer on the assumption that’s the dialog you have.
    – bmike
    Commented Aug 2, 2020 at 12:49

3 Answers 3


You can try to run the installer on your USB directly in Recovery mode.

Open up terminal and run ls /volumes. Identify your USB, and then run /volumes/<USB Name>/Install\ macOS\ Catalina.app/Contents/MacOS/InstallAssistant. The macOS installer should appear.

If it did not launch, you can copy your installation partition on the USB over to your internal drive. In Disk Utility, you can create a new partition on the internal drive and "restore" the USB drive to the new partition you just created. Then, select your internal installation partition as a boot drive and proceed to standard installation.

  • USB disk isn't available as a volume in the 'Restore from' dialog
    – Rob
    Commented Feb 15, 2021 at 17:08
  • This worked here for Big Sur. /volumes/<USB Name>/Install\ macOS\ Big\ Sur.app/Contents/MacOS/InstallAssistant Commented Feb 15, 2021 at 22:18
  • @Rob Does the terminal command work for you? Output of diskutil list?
    – Joy Jin
    Commented Feb 17, 2021 at 2:12
  • 1
    Thanks! Worked for Big Sur like a charm! Commented Mar 7, 2021 at 22:58
  • This saved me. I kept getting installation errors inside Internet Recovery, and I wasn't allowed to boot from the install USB. Using this method I could get into the Internet Recovery environment, and then start an installation from USB from there!
    – Ambroos
    Commented Sep 20, 2021 at 20:53

The disk (that you erased) contains a 'Secure Token' for the admin user. You need to recreate it before you can change the settings.

First, reinstall the OS using Internet Recovery. Or install over Target Disk mode from another Mac.

The Setup Assistant on first boot will provide the Secure Token for the admin user created. Otherwise, you'll have to manually create the token for the admin user once you've got a working system.

sysadminctl interactive -secureTokenOn [admin user shortname] -password -

(you will be asked to authenticate).

diskutil apfs updatePreboot /

See this answer, which covers much of the same ground.

"No administrator was found" in Startup Security Utility

  • I don't completely understand what your commands do, and whether they are necessary once someone is able to reinstall an OS. Should I include your commands in my answer?
    – Joy Jin
    Commented Jun 17, 2022 at 11:44

I am going to guess you ended up with a firmware password and aren’t seeing the images here due to some removals of OS that the system expected.

If so, you will need to get Apple to unlock the device by providing original proof of purchase if you can’t recall and enter the passwords that were entered into the T2 / Secure Enclave. The T2 encrypts the storage with a device key and as you add admin accounts, their password and identity is asssociated with the key to unlock the storage so you would normally provide that admin password to retrieve the key to make a change. This doesn’t really need an admin user - just one authorized to perform the storage unlock and change the boot sequence. Typically that’s an admin since typically only one account is on a Mac out of the box.

The good news is your hardware is fully capable of internet boot, so I would try recovery from the internet to drop on macOS and see if you can unlock and configure things with a new OS from Apple being trusted and installed.

Supporting Macs at work, we override all three of the items in the KB you reference with Internet Recovery and an erase. For firmware passwords, unless we have an MDM unlock, we do go to Apple service for that just like consumers do in the end, but it’s rare we lose control of most devices in that manner. Hopefully you get a trusted install from the internet and can reinstall Catalina without using USB.

  • Thanks @bmike, but I tried to install the OS from the net more than 5 times, it goes until it remains 4 minutes to finish the progress, and stops with error cannot decode raw data. Commented Aug 2, 2020 at 18:23
  • Also I never had set any password for T2, but I think it has used the admin user that previously was exist on my old deleted macOS. I Have that user's password but unfortunately it doesn't open any dialog to enter the password Commented Aug 2, 2020 at 18:24
  • What does Apple support say if you chat online with them, @AhmadBehzadi ?
    – bmike
    Commented Aug 2, 2020 at 18:35
  • I hasn't received any response yet. (Email) Do they have online chat? Commented Aug 2, 2020 at 18:48
  • Try support.apple.com @AhmadBehzadi - you've got three detailed answers for your Intel Mac and a bonus answer for M1 / Apple Silicon that won't work for you
    – bmike
    Commented Apr 4, 2023 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .