2

hope you can help me here. My MacBook Pro 2019, 16 inches, with a T2 security chip, systematically times out when trying to reinstall Catalina in recovery mode, after erasing the main drive. The T2 chip dissallows booting from external drive, when trying to create an offline bootable installer.

What I've done:

  1. Enter recovery mode (boot with Command + R pressed)
  2. Erased the hard drive to make a fresh installation of Catalina,
  3. Started the reinstall Catalina utility, which fetches Catalina from Apple servers.
  4. Everything goes smooth until 90% of the installation, when it times out. I've tried this many times, on different internet connections.
  5. Made an external bootable drive with a Catalina offline installer I found using the Catalina Patcher software.
  6. Pluged the external drive to the Macbook. Problem: the Macbook does not allow to boot from external drives because of the T2 chip.
  7. Tried to change the permissions to be able to boot from the external drive through the "Startup Security Utility" app (in recovery mode), but it requests admin privileges, and there is no admin in the computer (as I erased the main drive in step 1), so I get the "No administrator was found" error.

Please help!

8
  • Do you have access to another Mac? If you connect them with a USB-C cable, boot in Target Disk mode and use the "good" Mac to format and reinstall macOS on the "lost" Mac. You should also be able to use the Startup Security Utility because you'll now have an admin user to authenticate to.
    – Allan
    Oct 10, 2020 at 14:51
  • Can you boot up to a Time Machine backup?
    – benwiggy
    Oct 10, 2020 at 15:01
  • Thanks for your replies. I do have another Mac but not an USB cable. Will try to find one. I don't have a Time Machine Backup.
    – alek
    Oct 10, 2020 at 15:03
  • @Allan, my other computer is a 2012 macbook pro running high sierra. is it possible to boot on target disk mode through USB? or do I need a Thunderbolt cable on the old Mac's side?
    – alek
    Oct 10, 2020 at 15:22
  • I've never tried it with anything that old but I do think it can be done with a TB cable/adapter.
    – Allan
    Oct 10, 2020 at 15:24

1 Answer 1

1

This is how I solved the issue.

You need another Apple computer running Catalina.

  1. Make a time machine backup of the working computer.
  2. Boot the non-working computer in recovery mode.
  3. Recover from that backup.
  4. Continue from there...

Hope this helps other people.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .