4

I would like to download and view Canadian Immigration Form 1294E, the application to be filed by a non-Canadian person living overseas who wishes to come to Canada for study. I live in the US. The Canadian Immigration URL to download this form is here. When I go to that URL, I'm confronted with a dialog that says:

Please wait...

If this message is not eventually replaced by the proper contents of the document, your PDF viewer may not be able to display this type of document. You can upgrade to the latest version of Adobe Reader for Windows®, Mac, or Linux® by visiting http://www.adobe.com/go/reader_download.

For more assistance with Adobe Reader visit http://www.adobe.com/go/acrreader.

I waited minutes, but no file was downloaded. I then navigated to Adobe to update my computer's Reader, selected download, waited for the installation to complete (replacing an earlier version of Reader), then restarted the computer. Then again navigating to the Canadian Immigration URL, the same dialog appears and no .pdf is downloaded.

Another Canadian Immigration page has a drop-down that allows the user to select a specific form. Using that page again results in no download and the same dialog.

My iMac runs macOS 10.15.5, Safari 13.1.1, and the computer has Acrobat Reader DC version 20.009.20063, dated May 3, 2020. This sure seems like it'd be the "latest version." I also tried with Chrome v.83.0.4103.97 (the latest macOS version), and the same dialog was displayed.

The Wayback Machine retrieves only the same error dialog.

What might I try to retrieve this document?

  • 1
    Wow - that’s a hostile site - downloading a PDF should be hard to mess up, but maybe they have reasons to need windows software. The problem isn’t your adobe / PDF on mac / iOS / iPadOS but the site isn’t sending the data... Maybe messing with your browser headers gets their server to deliver the PDF? The server is fingerprinting you incorrectly. – bmike Jun 13 '20 at 17:28
  • 1
    Have you tried other browsers? – lhf Jun 13 '20 at 17:35
  • 1
    @lhf Safari, Chrome, and Firefox. Same response. I wonder if a PC would be successful. – DavidSupportsMonica Jun 13 '20 at 17:44
  • PDF has a lot of features. To me, this seems like they’re trying to actually load the form from the viewer itself rather than when downloading in the browser. So, the problem might be that no sane viewer supports downloads within PDFs. Good luck getting this to work... Maybe, your best bet is to Google for alternative PDFs via filetype:pdf (e.g. google.com/…) – Florian Wendelborn Jun 13 '20 at 17:44
  • 2
    Using Firefox I get the error message but FF offers a download button (upper left, page icon with a down arrow in it) and downloading from that button. Then I was able to open it with Adobe Acrobat and get the (presumably) whole form. I would bet that if I had the Adobe Acrobat plugin activated it might open directly in the browser. – Steve Chambers Jun 13 '20 at 18:50
3

I was finally able to download the Canadian immigration .pdf document.

The solution was to use Firefox, and to reset FF's preferences regarding .pdf files from "Open in browser" to "save file." I have been unable to find a similar setting in Safari.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .